[email] Deal with fonts not including all of the glyphs from the Unicode miscellaneous symbols block

RESOLVED WONTFIX

Status

Firefox OS
Gaia::E-Mail
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: daleharvey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
When I get emails with unicode titles it is not displayed properly
(Reporter)

Comment 1

3 years ago
Created attachment 8561082 [details]
2015-02-08-19-30-15.png
I signed up for spam from Travel Republic just now to figure out what the mystery character was.  (Normally you'd want to provide the email's source as described at https://wiki.mozilla.org/Gaia/Email/ProvidingEmailsForDebugging so we can figure out what's going wrong.)

It turns out it's a \u2600 ☀ "black sun with rays" and this is a font issue; on a desktop computer with font coverage, the WebIDE's DOM Inspector shows that we properly decoded everything.  Some quick experimentation shows we're also missing out on ☂, ☃, ☄, ☢, ☣, and many others.  (But we do have ☁, ★, and ☆!)

http://en.wikipedia.org/wiki/Miscellaneous_Symbols is a pretty good reference on the symbols block.

This seems like a system issue, but I'm not seeing an existing bug for this, so I'll file a new one against our fonts in Firefox OS :: General (where the other font bugs seem to have ended up) that blocks this bug.
Summary: Title doesnt correctly show unicode → [email] Deal with fonts not including all of the glyphs from the Unicode miscellaneous symbols block
Depends on: 1130912

Comment 3

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.