Closed Bug 1130942 Opened 5 years ago Closed 5 years ago

[v2.2] Investigate test_marketplace_packaged_app.py failure

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 affected)

RESOLVED FIXED
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: echang, Unassigned)

References

Details

Attachments

(1 file)

Traceback (most recent call last):
  File "/home/ericcc/repo/echangmoz/zz/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette_test.py", line 268, in run
    testMethod()
  File "/home/ericcc/repo/echangmoz/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/marketplace/test_marketplace_packaged_app.py", line 50, in test_search_and_install_app
    Wait(self.marionette).until(lambda m: m.title == self.app_title)
  File "/home/ericcc/repo/echangmoz/zz/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TEST-INFO took 112535ms


First fail 
Build ID               20150208162504
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.201049
Firmware Date          Sun Feb  8 20:11:02 EST 2015
Bootloader             L1TC000118D0


+++ This bug was initially created as a clone of Bug #1116456 +++

test_marketplace_packaged_app.py has failed in the last Jenkins run.

http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.smoke/226/HTML_Report/

I was able to reproduce the error locally and it looks like the installed app is not the expected one. The issue can also be reproduced manually since after we input the search term the app we are expecting is not returned at all.

Repro rate 5/5

expected title = Privileged App Test
the first app returned (the one we install) has the title mozLauncher Test
QA Whiteboard: [fxosqa-auto-backlog+]
It seems like the test-webapi-permissions app is not there anymore in the Marketplace.
This is already the 2nd time in a short time that this Marketplace test is failing. Perhaps it is better to move this test over to the Marketplace tests and remove this from gaia-ui tests?
Flags: needinfo?(krupa.mozbugs)
(In reply to Martijn Wargers [:mwargers] (QA) from comment #1)
> It seems like the test-webapi-permissions app is not there anymore in the
> Marketplace.
> This is already the 2nd time in a short time that this Marketplace test is
> failing. Perhaps it is better to move this test over to the Marketplace
> tests and remove this from gaia-ui tests?

https://marketplace.firefox.com/app/test-webapi-permissions is still available. We should keep this running on gaia-tests since installing a packaged app is a common usecase on the phone.
Flags: needinfo?(krupa.mozbugs)
(In reply to krupa raj[:krupa] from comment #2)
> https://marketplace.firefox.com/app/test-webapi-permissions is still
> available. We should keep this running on gaia-tests since installing a
> packaged app is a common usecase on the phone.

When visiting that page, I get:
Oh nee!
The app requested is not public.

Can this app be made public then, again?
Flags: needinfo?(krupa.mozbugs)
(In reply to Martijn Wargers [:mwargers] (QA) from comment #3)
> (In reply to krupa raj[:krupa] from comment #2)
> > https://marketplace.firefox.com/app/test-webapi-permissions is still
> > available. We should keep this running on gaia-tests since installing a
> > packaged app is a common usecase on the phone.
> 
> When visiting that page, I get:
> Oh nee!
> The app requested is not public.
> 
> Can this app be made public then, again?

Done.
https://marketplace.firefox.com/app/test-webapi-permissions/
Flags: needinfo?(krupa.mozbugs)
Ok, thanks. That means this should be resolved.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
I tried automation, and reproduced manually in marketplace or in browser, I still got the "INVALID_URL" error.

Traceback (most recent call last):
  File "/home/ericcc/repo/echangmoz/zz/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette_test.py", line 268, in run
    testMethod()
  File "/home/ericcc/repo/echangmoz/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/marketplace/test_marketplace_packaged_app.py", line 30, in test_search_and_install_app
    results = marketplace.filter_search_all_apps()
  File "/home/ericcc/repo/echangmoz/gaia/tests/python/gaia-ui-tests/gaiatest/apps/marketplace/app.py", line 27, in filter_search_all_apps
    self.select('All apps', tap_close=False)
  File "/home/ericcc/repo/echangmoz/gaia/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 115, in select
    self.wait_for_select_closed(*_close_button_locator)
  File "/home/ericcc/repo/echangmoz/gaia/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 95, in wait_for_select_closed
    self.wait_for_element_not_displayed(by, locator)
  File "/home/ericcc/repo/echangmoz/gaia/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 50, in wait_for_element_not_displayed
    lambda m: not m.find_element(by, locator).is_displayed())
  File "/home/ericcc/repo/echangmoz/zz/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TEST-INFO took 48798ms

Build ID               20150209162506
Gaia Revision          21cce750c095a3f815275fe5439fa9dbfe3dfc6b
Gaia Date              2015-02-09 21:57:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/41ccc5328740
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.194557
Firmware Date          Mon Feb  9 19:46:08 EST 2015
Bootloader             L1TC000118D0
Ok, this used to work earlier in the day. I guess something is broken again in Marketplace. Krupa might know more.
Status: RESOLVED → REOPENED
Flags: needinfo?(krupa.mozbugs)
Resolution: FIXED → ---
https://marketplace.firefox.com/app/test-webapi-permissions/ should work. Sorry about the confusion.
Flags: needinfo?(krupa.mozbugs)
It works fine wtih build(#c7), thanks a lot.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.