Email notifications of comment changes should include comment number

RESOLVED DUPLICATE of bug 236533

Status

()

P3
enhancement
RESOLVED DUPLICATE of bug 236533
17 years ago
6 years ago

People

(Reporter: bbaetz, Assigned: preed)

Tracking

Details

(Reporter)

Description

17 years ago
Occasionally I grep through my bugmail looking for a recent mail which I want to
refer to. However, I can't refer directly to that comment# without looking in
bugzilla.

We should change:

------- Additional Comments From foo@bar.com  xxxx-xx-xx xx:xx -------

to be

----- Additional Comment #xx From foo@bar.com  xxxx-xx-xx xx:xx ------
(Reporter)

Comment 1

17 years ago
*** Bug 113504 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
I thought about doing this when the patch was originally being done to add
comment #xx to the show_bug page, but the way things are currently structured,
processmail has no way of knowing what the comment number is.

Comment 3

17 years ago
This is not installation. To email
Assignee: zach → jake
Component: Installation & Upgrading → Email Notifications
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18
Changing default owner of Email Notifications component to JayPee, a.k.a.
J. Paul Reed (preed@sigkill.com).  Jake will be offline for a few months.
Assignee: jake → preed
(Reporter)

Comment 5

16 years ago
*** Bug 171424 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: Email notifications of comment changes should include comment # → Email notifications of comment changes should include comment number

Updated

16 years ago
OS: Linux → All
Hardware: PC → All

Comment 6

15 years ago
The need for this is especially apparent for anyone following comments submitted
for bug #62429, in which people refer to other comments by number and there are
over 260 comments. If someone refers to the last comment by number and you don't
know the number of the comment you're reading, you wouldn't know they were
talking about the last comment, for example.

Two other issues related to this bug:
1. Should the summary be reworded slightly? "comment changes" seems somewhat
confusing to me. Perhaps it can be "Email notifications of comments should...".

2. This bug seems to have been idle for a while (save for tweaks to some of its
fields). Is this because the situation described in comment #2 (regarding
processmail not knowing the comment number) is difficult to fix? Are there plans
to implement this in the near future?
(Assignee)

Comment 7

15 years ago
re: comment 6: Are there plans to implement this in the near future?

Sure... the bug report seems to make sense as filed. But there are a lot of
other bugs before this one... so the problem is all in the definition of "near
future." Yours is probably different than mine.

But, this *is* open source after all, so feel free to take a whack at it (or
hire someone to take a whack at it ;-)

Comment 8

15 years ago
Making bug 225221 block this, as the fix will be relatively trivial after that
one is done.
Depends on: 225221
All 2.18 bugs that haven't been touched in over 60 days and aren't flagged as
blockers are getting pushed out to 2.20
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20

Updated

14 years ago
Severity: normal → enhancement

Comment 10

14 years ago

*** This bug has been marked as a duplicate of 236533 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
clearing target of DUPLICATE/WONTFIX/INVALID/WORKSFORME so they'll show up as
untriaged if they get reopened.
Target Milestone: Bugzilla 2.20 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.