gUM: When requesting video in Firefox OS > 2.2 image is distorted.

RESOLVED DUPLICATE of bug 1146637

Status

defect
RESOLVED DUPLICATE of bug 1146637
4 years ago
4 years ago

People

(Reporter: borjasalguero, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

STR:

- Check [1] and request for video stream
- Check video shown

Expected:
Regardless the resolution requested, image aspect-ratio should be working properly

Currently:
Image is distorted.

This seems to be related with the new changes added to the preview of the photo within camera app, so it could be useful in order to open a regression window. I hope it helps!


[1] http://mozilla.github.io/webrtc-landing/gum_test.html
Hi Mike! Following the discussion we had in [1] I've opened this bug. Let me know if you need more info about the steps to reproduce. Do you know who could help us fixing this? Thanks!

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1103400#c19
Flags: needinfo?(mhabicher)
Andrew, what do you think about adding a "getusermedia" mode to ICameraControl?
Flags: needinfo?(mhabicher) → needinfo?(aosmond)
Borja, does this solve your problem? The preview looks distorted on my flame no matter what (2.2, without this patch, with this patch) but at least with this change the correct preview size should be selected (matching aspect ratio to the picture size, on flame this results in the same value for both 320x240 as requested) and mirror previous behaviour.
Flags: needinfo?(aosmond)
Attachment #8561758 - Flags: feedback?(borja.bugzilla)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1146637
Attachment #8561758 - Flags: feedback?(borja.bugzilla)
You need to log in before you can comment on or make changes to this bug.