Allow launching private browser via a search app message

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: kgrandon, Assigned: kgrandon)

Tracking

unspecified
2.2 S6 (20feb)
x86
Mac OS X

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
The search app will have a button to enter private browsing. I'm not sure what the long term approach will be, but since it already opens up a channel with the rocketbar code, we could use that for now.
Created attachment 8561364 [details] [review]
[PullReq] KevinGrandon:bug_1131024_launching_private_window_message to mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8561364 [details] [review]
[PullReq] KevinGrandon:bug_1131024_launching_private_window_message to mozilla-b2g:master

Alive - Could you take a look and let me know if you think this is ok? This will allow the search app to trigger a private window.

Come tap me on the shoulder if you have any questions/suggestions :) Thanks!
Attachment #8561364 - Flags: review?(alive)
Comment on attachment 8561364 [details] [review]
[PullReq] KevinGrandon:bug_1131024_launching_private_window_message to mozilla-b2g:master

One concern is coupling - please use Service.register/Service.request or at least event dispatching.
Attachment #8561364 - Flags: review?(alive) → review+
(Assignee)

Comment 4

3 years ago
Moved to using events for now, as I'm not still not sure what is best for what. We can always port to Service.register/request if needed.
Keywords: checkin-needed
Whiteboard: [systemsfe]

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

3 years ago
Comment on attachment 8561364 [details] [review]
[PullReq] KevinGrandon:bug_1131024_launching_private_window_message to mozilla-b2g:master

This is necessary work to support private browsing in 2.2.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature implementation.
[User impact] if declined: Can't use private browsing.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Fairly self-contained to browsing functionality, so low risk.
[String changes made]: No.
Attachment #8561364 - Flags: approval-gaia-v2.2?(fabrice)
Attachment #8561364 - Flags: approval-gaia-v2.2?(fabrice) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/14f75df6c5c65a04a22f3905dcb6c26edf336764
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S6 (20feb)
This bug has been verified as "pass" on latest nightly build of Flame v2.2 & master.

STR:
1.Launch Browser app.

Actual results: It shows the 'New private window' button under 'Top Sites' thumbnails, and user can use the 'New private window' button normally.
See attachment: verified_Flame_v2.2.3gp
Reproduce rate: 0/10


Device: Flame v2.2 (Verified) 
Build ID               20150712002506
Gaia Revision          84d0c76370dcd3d25813b00de55194730884355b
Gaia Date              2015-07-09 13:09:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d59402ba85a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150712.040416
Firmware Date          Sun Jul 12 04:04:27 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (Verified)
Build ID               20150712010205
Gaia Revision          e4b63559eba364892867eb381c3002d6518e5d6a
Gaia Date              2015-07-10 14:29:23
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eab21ec484bb
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150712.050401
Firmware Date          Sun Jul 12 05:04:12 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.