Intermittent TEST-UNEXPECTED-TIMEOUT | /webaudio/the-audio-api/the-gainnode-interface/test-gainnode.html | expected OK

RESOLVED FIXED

Status

()

defect
P3
normal
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: padenot)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

12:10:59 INFO - TEST-START | /webaudio/the-audio-api/the-gainnode-interface/test.html
12:10:59 INFO - PROCESS | 1899 | WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
12:10:59 INFO - PROCESS | 1899 | pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
12:10:59 INFO - PROCESS | 1899 | nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:14040:21
12:10:59 INFO - PROCESS | 1899 | __marionetteFunc@dummy file:18:30
12:10:59 INFO - PROCESS | 1899 | @dummy file:24:3
12:10:59 INFO - PROCESS | 1899 | executeWithCallback@chrome://marionette/content/marionette-listener.js:700:5
12:10:59 INFO - PROCESS | 1899 | executeAsyncScript@chrome://marionette/content/marionette-listener.js:593:3
12:10:59 INFO - PROCESS | 1899 | JavaScript warning: http://web-platform.test:8000/webaudio/js/lodash.js, line 97: Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead
12:11:13 INFO - PROCESS | 1899 | ImportError: No module named pygtk
12:11:13 INFO - PROCESS | 1899 | MARIONETTE LOG: INFO: Timeout fired
12:11:14 INFO - TEST-UNEXPECTED-NOTRUN | /webaudio/the-audio-api/the-gainnode-interface/test.html | GainNode - expected PASS
12:11:14 INFO - TEST-UNEXPECTED-TIMEOUT | /webaudio/the-audio-api/the-gainnode-interface/test.html | expected OK
12:11:14 INFO - TEST-INFO took 14786ms
This is spiking horribly recently. Any recent changes that come to mind, Paul?
Flags: needinfo?(padenot)
Hrm, I had no idea those existed. I've pushed a patch with some instrumentation here (and assigned myself so I don't forget this bug):

https://treeherder.mozilla.org/#/jobs?repo=try&revision=cf0edbf1e8c8
Assignee: nobody → padenot
Flags: needinfo?(padenot)
I can't repro at all (see comment 40), something very fishy is going on. And looking at the orange factor, this does not happen anymore, but bug 1149122 just got filed...
Duplicate of this bug: 1149122
(In reply to Paul Adenot (:padenot) from comment #53)
> I can't repro at all (see comment 40), something very fishy is going on. And
> looking at the orange factor, this does not happen anymore, but bug 1149122
> just got filed...

Bug 1140452 is the likely reason. It's a PITA to deal with.
Could we at least give it a less tiresome name, so we wouldn't have to star it manually every time?
Well, even if I can't figure out how to rename it myself, and I can't figure out how to skip the test myself, at least I do know how to hide this entire suite, and how to choose something from the Visibility Requirements list to cover "tests named 'test.html' are not acceptable."
Posted patch rename.diffSplinter Review
(In reply to Phil Ringnalda (:philor) from comment #105)
> Well, even if I can't figure out how to rename it myself, and I can't figure
> out how to skip the test myself,

What was hard to figure out? This is in a README file in the testing/web-platform directory.
Attachment #8622023 - Flags: review?(Ms2ger)
By far the hardest part of that would be imaging that there would be a README in testing/ which would actually say something useful. Reftest is the only suite I can think of which has one worth looking at, and it's not in testing/. Mochitest has one, which only links to a somewhat outdated wiki page from which as I remember it it's six clicks through two sites to get to a how to disable a test; xpcshell is only three clicks, but the final one is to code rather than documentation, and the code is no longer actually where the link goes.

Of course, since it's a visibility requirement (https://wiki.mozilla.org/Sheriffing/Job_Visibility_Policy#Has_sufficient_documentation) that the docs be linked from https://developer.mozilla.org/en-US/docs/Mozilla/QA/Automated_testing I should of course have just looked there, except I'm not actually new here, so I knew the odds were microscopic that it or anything else would be.
Comment on attachment 8622023 [details] [diff] [review]
rename.diff

Review of attachment 8622023 [details] [diff] [review]:
-----------------------------------------------------------------

Make sure the metadata is correct, like with hg mv --after.
Attachment #8622023 - Flags: review?(Ms2ger) → review+
Keywords: leave-open
Keywords: leave-open
Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | /webaudio/the-audio-api/the-gainnode-interface/test.html | expected OK → Intermittent TEST-UNEXPECTED-TIMEOUT | /webaudio/the-audio-api/the-gainnode-interface/test-gainnode.html | expected OK
Component: Audio/Video → Web Audio
Priority: -- → P3
This has been re-enabled and works fine, closing.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.