Closed Bug 1131465 Opened 6 years ago Closed 6 years ago

gecko: Use tc-vcs to download gecko in emulator images.

Categories

(Taskcluster :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jlal, Assigned: jlal)

References

Details

While we use tc-vcs internally in mozharness there appears to be a race when using tc-vcs for repo (which does not include gecko) and mozharness when the sources are cached which leads to a skipped update causing issues like this:

http://docs.taskcluster.net/tools/task-inspector/#V3eVOe5HSL-TYMdYwcn5pw/0

Solution is to use tc-vcs to download gecko prior to invoking mozharness...
https://hg.mozilla.org/mozilla-central/rev/03ce732e9266
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Duplicate of this bug: 1130758
Component: TaskCluster → General
Product: Testing → Taskcluster
Target Milestone: mozilla38 → mozilla41
Version: unspecified → Trunk
Resetting Version and Target Milestone that accidentally got changed...
Target Milestone: mozilla41 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.