Sea Monkey 2.32.1 running on OSX 10.7.5 / Composer editor in <HTML> source display / Find function no longer works /can only access find with Replace function.

RESOLVED DUPLICATE of bug 1070492

Status

SeaMonkey
Composer
RESOLVED DUPLICATE of bug 1070492
3 years ago
3 years ago

People

(Reporter: simon.boswell@siba.fi, Unassigned)

Tracking

SeaMonkey 2.32 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.78.2 (KHTML, like Gecko) Version/6.1.6 Safari/537.78.2

Steps to reproduce:

Find function has stopped working in <HTML> Source editing mode. Won't work from CMD F, Find in Edit Menu, or Find icon on Composer's own page.
Replace DOES work… so that is a temporary workaround. BUT the find function also worked perfectly until this latest version


Actual results:

Nothing!


Expected results:

Finding of requested text in the HTML document.

Comment 1

3 years ago
Is a DUP of Bug 1070492 - Composer doesn't handle Ctrl+F when working with the document's HTML code ?

Note that Ctrl+H (Find & Replace) will work as a Find, so long as you do not enter a Replace string.
(Reporter)

Comment 2

3 years ago
Unfortunately, neither of "therube"'s comments are true. I've been using Sea Monkey Composer as my main platform for creating and editing HTML/Javascript code for several years... and until recently it has ALWAYS supported the text find command on the Mac platform. Sea Monkey's own Edit drop-down menu STILL offers Find directly and also with the shortcut Command-F when working in <HTML> Source mode. The problem is that it no longer works. Selecting Find from the drop-down menu now gets no response. I have resorted to the Find & Replace option as a workaround, for which the shortcut keys on the Mac platform are Command+Alt+F, NOT Ctrl+H as "therube" suggests. (The drop-down Sea Monkey menu itself gives the shortcut Command+Alt+F, by the way.)
My main point is that the Find function was working just fine until Sea Monkey 2.32.1 and, as the drop down Edit menu still shows it as an available option, the problem has to be a new bug.

Comment 3

3 years ago
I can see this on Mac with 2.29 up to trunk (and on Linux trunk), and it's indeed a dupe of bug 1070492.

Simon, please note that bug 1070492 is still relatively new and that the shortcuts mentioned by therube or those used by Linux and Windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1070492
You need to log in before you can comment on or make changes to this bug.