Add an help link to 'Unknown Account' error msg on the Sync log-in page in zh-CN

VERIFIED FIXED

Status

Mozilla Localizations
zh-CN / Chinese (Simplified)
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Jing Zhang, Assigned: YF (Yang))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Many Chinese users are trying to use Chinese local account (which is used in local community website and other local services) to log in Firefox Sync and seeing the 'Unknown Account' message. Beijing office has received lots of complains about it everyday.
 
We'd like to propose adding an help article link to the unknown account prompt.
This can be done without any code change to fxa-content-server, only a zh-CN
l10n string change is necessary:

from
"Unknown account. <a href="/signup">Sign up</a>" 
"未知账 号。<a href="/signup">注册</a>"

to
#The Revised l10n with the help link#
"未知账号(<a href="http://test.example.com/"> 帮助</a>)。<a href="/signup">注册</a>”
(Reporter)

Comment 1

3 years ago
> to
> #The Revised l10n with the help link#
> "未知账号(<a href="http://test.example.com/"> 帮助</a>)。<a href="/signup">注册</a>”

Here 'http://test.example.com/' will use http://firefox.com.cn/help/accounts/unknown/
(Assignee)

Comment 2

3 years ago
It on https://localize.mozilla.org/zh_CN/accounts/translate.html#search=%E6%9C%AA%E7%9F%A5%E8%B4%A6%E5%8F%B7&sfields=target&unit=1769732, a content script on fxa server.

Done, https://github.com/mozilla/fxa-content-server-l10n/commit/650f367f394610a7dd089109d4df270c71c9c6b3
Assignee: shaohua.wen → yfdyh000
Status: NEW → RESOLVED
Last Resolved: 3 years ago
OS: Mac OS X → All
QA Contact: shaohua.wen → steekid
Hardware: x86 → All
Resolution: --- → FIXED
(Assignee)

Comment 3

3 years ago
Confirmed on https://accounts.firefox.com/i18n/client.json and show in Firefox Sync error message.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 4

3 years ago
For China's Sync service, maybe it need modification too, because the users may login the international account in Chinese version. (so, including the string in English version)
The needs another help article link or supplement existing article? Please forward this opinion, thanks.


https://accounts.firefox.com.cn/i18n/client.json 's "Unknown account. ..."
(Reporter)

Comment 5

3 years ago
(In reply to YF (Yang) from comment #4)
Dear YF,
Thanks for your reminding. For users who have global FxAccount, there's an obvious entrance to switch sync service in our local webpage. So we do not put another help link to guide users the same thing.
Hi folks, Ryan here from the Firefox Accounts engineering team.

We were surprised to find this link on our production site, and since we have a policy of not allowing custom markup in l10n translations, it has been removed.  If it's necessary to have this sort of cross-linking, let's work together to find an officially-supported way of doing it.

Who is responsible for maintaining https://accounts.firefox.com.cn/ that I can work with on this?

(ni? to YF because it looks like Jng Zhang's account is no longer active)
Flags: needinfo?(yfdyh000)
(In reply to Ryan Kelly [:rfkelly] from comment #6)
> 
> Who is responsible for maintaining https://accounts.firefox.com.cn/ that I
> can work with on this?

Hi Ryan, that would be me.

> 
> (ni? to YF because it looks like Jng Zhang's account is no longer active)

Clearing ni since YF is from zh-CN l10n community and doesn't work in Beijing office.
Flags: needinfo?(yfdyh000)
Thanks Hector, I'll follow up via email.
You need to log in before you can comment on or make changes to this bug.