Fix ability to style NEW Pseudo-elements in DevTools

RESOLVED WORKSFORME

Status

DevTools
Inspector
RESOLVED WORKSFORME
4 years ago
a month ago

People

(Reporter: Kumar Harsh, Unassigned)

Tracking

36 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150209004026

Steps to reproduce:

Open the Inspector panel, select any node (which doesn't have a pseudoelement yet), say `#main`. Then go to the Rules sub-panel on the right hand side.

Now, right click on the panel, select "Add Rule" and write `#main::before {` and press tab (that's how actual styling for real elements works, right?)



Actual results:

POOF!
The line you just typed: `#main::before` is gone. Where is it? I can't even find it... It's not under the `Pseudo-elements` section, nor is it under `This Element` section.


Expected results:

I should have been able to add the actual styles for the element. Look at how Firebug does it to understand how irritating this issue is.
(Reporter)

Updated

4 years ago
Component: Untriaged → Developer Tools: Inspector
OS: Linux → All
Hardware: x86_64 → All
Version: 37 Branch → 36 Branch
Thanks for filing and sorry for the late answer. 
I just tested on Firefox 45, and it seems to be working now.

The selector is no longer removed and works as you would expect. I can't find the bug which fixed the issue so I'm just going to close as worksforme. 

Hopefully I did not misunderstand the issue, please reopen if there's any problem left! 

Inspector bug triage. Filter on CLIMBING SHOES.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.