Language pack download dialog too small

VERIFIED FIXED in mozilla1.0

Status

VERIFIED FIXED
17 years ago
11 years ago

People

(Reporter: Heiko.Nitzsche, Assigned: dveditz)

Tracking

({testcase})

Trunk
mozilla1.0
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

17 years ago
The language download dialog reachable by:

1. Select menu: View -> Download More
2. Select a language pack (checked for German)
3. The dialog pops up. The buttons at bottom
   of the dialog are not visible.

This looks like a general bug. I have seen this
also on Mozilla for HP-UX 10.20.

Comment 1

17 years ago
I'm also seeing this on Windows 98 with build 2002010703 when I go to a page
that has characters in an encoding I don't have a language pack for.
Created attachment 64532 [details] [diff] [review]
Remove height

The problem here is a hardcoded height. If you hardcode width and height, the
dialog can't autosize.
Moving to xpinstall for review.
Assignee: mpt → syd
Status: UNCONFIRMED → NEW
Component: User Interface Design → Installer: XPI Packages
Ever confirmed: true
QA Contact: zach → ktrina

Updated

17 years ago
Keywords: patch, review
(Assignee)

Comment 4

17 years ago
Comment on attachment 64532 [details] [diff] [review]
Remove height

r=dveditz
Attachment #64532 - Flags: review+
(Assignee)

Comment 5

17 years ago
taking to apply patch.
Assignee: syd → dveditz
Keywords: nsbeta1+
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 6

17 years ago
*** Bug 115716 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
guess you forgot it ? =)
(Assignee)

Updated

17 years ago
Attachment #64532 - Attachment is obsolete: true
(Assignee)

Comment 8

17 years ago
When I removed the height the dialog came up with just a title bar. In CSS you
can specify one and not the other, but in XUL if you specify one the other is
assumed to be 0 (very odd, if you ask me). The solution is to specify sizes in
CSS, or if you only want to specify one you must add a call to sizeToContent()
somewhere.

In any case this entire dialog is being re-worked as part of the "embeddable
XPI" bugs, and the fix for this bug is locked up with a bunch of other changes.
Didn't make the deadline, but I'll try to beg drivers to let me in.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 9

17 years ago
adt3 per traige
Whiteboard: [adt3]
(Assignee)

Comment 10

17 years ago
Landed embeddable XPInstall
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
I don't have an OS/2 machine to test this on. Can someone with OS/2 please
verify this is fixed?
(Assignee)

Comment 12

17 years ago
This started happening on non-localized windows builds as well, at least for
some systems (come to think of it, I used userChrome.css to bump my text size a
little), and the duped bug I think was with a JA locale. You could try one of
those things: if you can show that an old build was clipped you can then upgrade
to a fixed build to verify.

Comment 13

17 years ago
This bug has been occurring again for me in the nightly trunk builds (up to
2002061408) on Windows 98 for the past few weeks. To reproduce, go to
http://tw.news.yahoo.com/ or http://www.joins.com/ or http://www.nikkei.co.jp/
(dpending on what fonts you already have installed). 

Comment 14

17 years ago
ccing ruixu in Internationalization
I had trouble installing Japanese, Korean or Chinese in order to reproduce
Steve's steps. Would you mind trying to reproduce steps in Comment #13?

Comment 15

17 years ago
Langpack issue, IQA -> kasumi and Jimmy.

Kasumi and Jimmy,
Would you mind trying to reproduce steps in Comment #13? Thanks.

Comment 16

17 years ago
language pack installation process is changed.
We no longer have Select menu: View -> Download More feature.
How to confirm? 

Comment 17

17 years ago
vrfy fixed
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020718
Status: RESOLVED → VERIFIED
Keywords: patch, review → testcase
OS: OS/2 → All
Hardware: Other → All
Whiteboard: [adt3]
Product: Browser → Seamonkey

Updated

11 years ago
Component: Installer: XPI Packages → Installer
QA Contact: ktrina → general
You need to log in before you can comment on or make changes to this bug.