Private Browsing mask is not shown when window is maximized with Developer Edition theme, on Windows 7 Luna interface

RESOLVED WORKSFORME

Status

()

Firefox
Theme
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Kyungjoon Lee, Unassigned)

Tracking

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8562029 [details]
maximized_private_window.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150209004026

Steps to reproduce:

1. Prepare a Windows 7 environment with Luna theme.
2. Configure Firefox as follows:
    - Theme: Developer Edition theme
    - Toolbar: Menu Bar hidden
    - browser.tabs.drawInTitlebar = true
3. Open a Private Browsing window. (Ctrl+Shift+P)
4. Maximize the window.


Actual results:

There is no Private Browsing purple mask icon when the window is maximized.


Expected results:

There should be a Private Browsing purple mask icon when the window is maximized.

The mask appears as intended when the Menu Bar is forced on.
The mask appears as intended in Full Screen mode. (F11)
(Reporter)

Updated

3 years ago
Summary: Private Browsing mask is not shown when window is maximized on Windows 7 Luna interface → Private Browsing mask is not shown when window is maximized with Developer Edition theme, on Windows 7 Luna interface
Reproduced with Dev Edition 37.0a2 Win 7 64-bit, but it is fixed on 38.0a2. Marking as RWFM since the updates to 38 will be available soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → Theme
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.