Closed Bug 1131556 Opened 8 years ago Closed 8 years ago

crash in libstdc++.so@0x9ad

Categories

(Firefox for Android Graveyard :: Plugins, defect)

All
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ioana.chiorean, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
reports:
bp-1a746dfe-a810-4d4a-833b-e97502150210
bp-1c5fd6bb-424d-4a0f-8493-fc2352150210
bp-226be579-5e64-479a-9e92-192e22150210

=============================================================

Frame 	Module 	Signature 	Source
Ø 0 	libc.so 	libc.so@0x13b18 	
Ø 1 	libc.so 	libc.so@0x14435 	
Ø 2 	libstdc++.so 	libstdc++.so@0x9ad 	
Ø 3 	libstagefright.so 	libstagefright.so@0x6bac9 	
Ø 4 	libstagefright.so 	libstagefright.so@0x6ba2f 	
Ø 5 	libstagefright.so 	libstagefright.so@0x72305 	
Ø 6 	OMXCodec (deleted) 	OMXCodec (deleted)@0x2fcffe 	
Ø 7 	app_process 	app_process@0xe6 	
8 	libstagefright_foundation.so 	_ZN7android7hexdumpEPKvj 	
Ø 9 	libc.so 	libc.so@0x13eed 	
10 	libstagefright_foundation.so 	_ZN7android7hexdumpEPKvj 	
Ø 11 	app_process 	app_process@0xe6 	
Ø 12 	libstdc++.so 	libstdc++.so@0x9ad 	
Ø 13 	libutils.so 	libutils.so@0x16573 	
Ø 14 	libstagefright.so 	libstagefright.so@0x72553 	
Ø 15 	libstagefright.so 	libstagefright.so@0x74917 	
Ø 16 	libflashplayer.so 	libflashplayer.so@0x6b47e2 	
Ø 17 	libflashplayer.so 	libflashplayer.so@0x47ab13 	
Ø 18 	libflashplayer.so 	libflashplayer.so@0x6b47e2 	
Ø 19 	libflashplayer.so 	libflashplayer.so@0x6b47e2 	
Ø 20 	libflashplayer.so 	libflashplayer.so@0x46d3bf 	
Ø 21 	libflashplayer.so 	libflashplayer.so@0x6b47e2 	
Ø 22 	libflashplayer.so 	libflashplayer.so@0x6b47e2 	
Ø 23 	libflashplayer.so 	libflashplayer.so@0x4c5501 	
Ø 24 	libdvm.so 	libdvm.so@0x485b9 	
Ø 25 	libdvm.so 	libdvm.so@0x4c517 	
Ø 26 	libdvm.so 	libdvm.so@0x9a64a 	
Ø 27 	libflashplayer.so 	libflashplayer.so@0x4c8e23 	
Ø 28 	libflashplayer.so 	libflashplayer.so@0x4c8e23 	
Ø 29 	libflashplayer.so 	libflashplayer.so@0x4c58c7 	
Ø 30 	libflashplayer.so 	libflashplayer.so@0x4c8963 	
Ø 31 	libflashplayer.so 	libflashplayer.so@0x6b47e2 	
Ø 32 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x263e4fe 	
Ø 33 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0xdbde1a8 	
Ø 34 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x240060 	
Ø 35 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x4b11d0 	
Ø 36 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x470c16 	
Ø 37 	org.mozilla.firefox_beta-1.apk 	org.mozilla.firefox_beta-1.apk@0xca1caa 	
Ø 38 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x3b5f39 	
Ø 39 	libflashplayer.so 	libflashplayer.so@0x4c8e23 	
Ø 40 	libc.so 	libc.so@0x10c5e 	
Ø 41 	libflashplayer.so 	libflashplayer.so@0x4c892b
Probably nothing we can do here. Snorp, wontfix?
Component: General → Plugins
Keywords: steps-wanted
I'm able to reproduce this crash on Acer Iconia 10.1 (3.2.1) every time I try to play a flash video on Youtube desktop site 
https://crash-stats.mozilla.com/report/index/c9374b3d-7913-4807-a844-14b772150225

See also https://bugzilla.mozilla.org/show_bug.cgi?id=750198, which occurs when playing a flash video on Android 2.3.x, but has a different crash signature.
Looks like Flash is crashing while trying to decode the video. I really don't think we can do anything there, as that code is all out of our hands.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard

Removing steps-wanted keyword because this bug has been resolved.

Keywords: steps-wanted
You need to log in before you can comment on or make changes to this bug.