css keyframes animation name missing in the rule-view

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 months ago

People

(Reporter: pbro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8562129 [details]
Screenshot 2015-02-10 16.32.08.png

The rule-view shows the @keyframes rule when there is a css animation applied to the current node in the inspector.
It shows it in a separate section at the end of the rule-view.

It looks like there was a regression with this feature, because the animation name is supposed to appear in the section header, but not it shows "Inherited from" instead.
(Reporter)

Comment 1

4 years ago
It seems to only occur on dev-edition.
I will attach a test page and STR.
(Reporter)

Comment 2

4 years ago
Created attachment 8562139 [details]
animation.html

STR
- open the attached test page in dev-edition
- open the inspector
- select the .simple-animation node
- check the rule-view
(Reporter)

Comment 3

4 years ago
If I select the .multiple-animations node instead, I see the 2 expected keyframes sections, but only one has the right section header.
(Reporter)

Comment 4

4 years ago
Created attachment 8562147 [details]
keyframes.gif

Here's an animated gif showing what I see on the test page.
(Reporter)

Comment 5

4 years ago
I did a little debugging and found out that the keyframes section header is created correctly when createExpandableContainer is called [1], but it gets replaced with an incorrect header when the CssRuleViewRefreshed event gets dispatched [2].

[1] http://mxr.mozilla.org/mozilla-central/source/browser/devtools/styleinspector/rule-view.js#1811
[2] http://mxr.mozilla.org/mozilla-central/source/browser/devtools/styleinspector/rule-view.js#1616
Inspector bug triage. Filter on CLIMBING SHOES.

Cannot reproduce the issue described in the STRs. 
For .simple-animation the header of the rule view section has the expected title : "Keyframes move"
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.