If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Toolbar folders should behave like normal menus

RESOLVED WONTFIX

Status

SeaMonkey
Bookmarks & History
--
minor
RESOLVED WONTFIX
16 years ago
5 years ago

People

(Reporter: Andy Lyttle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112011

Reproducible: Always
Steps to Reproduce:
1.  Click-and-hold on a folder in the toolbar.  The menu opens.
2.  Drag the mouse to the left or right.

Actual Results:  Nothing happens; the menu remains open.

Expected Results:  Two options:
A) the folder should move within the toolbar.  This would be consistent with
dragging bookmarks.

B) the menu should close as you move the mouse away, and reopen if you move the
mouse back.  If you move the mouse over another folder, that menu should open. 
This would be consistent with normal menus.

I'm leaning towards option B myself.  See bug 32494 for notes about normal menu
behavior.

Comment 1

16 years ago
This bug is a dupe of both bug 83214 and bug 32494.

Comment 2

16 years ago
Thanks Chris.

*** This bug has been marked as a duplicate of 83214 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Bug 83214 says you should be able to move toolbar folders by dragging while
holding a modifier key.  Without that modifier key, folders should behave like
normal menubar menus (option B above).  This is not a dup of 32494, which is
about normal menubar menus misbehaving.

Reopening and changing the summary.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Dragging folder in toolbar does nothing → Toolbar folders should behave like normal menus

Comment 4

16 years ago
dupe of bug 24690?
(Reporter)

Comment 5

16 years ago
Only if 24690 is expanded to include the click-and-hold behavior.  Definitely
related issues, and probably should be looked at together.

Comment 6

16 years ago
->default assignee.
Assignee: pchen → ben
Status: UNCONFIRMED → NEW
This is unlikely to be fixed at least by default, as the expected behaviour for
menus is to allow the user to click and drag down into the popup then release to
select a sub-item, which clashes with rearranging, which is why the ability to
drag folders around was turned off. 
Status: NEW → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Future

Comment 8

16 years ago
I agree, Ben.  Should this be WONTFIX?
(Reporter)

Comment 9

16 years ago
As I said above, we're not trying to make click-and-drag move folders; that's
covered by bug 83214.

However, if you click-and-hold a folder and drag to the side, it is perfectly
reasonable for an adjacent folder menu to open.  Drag back, and the original
folder menu should open.  This behavior does not at all get in the way of
dragging down to select items.

Normal menus in the menu bar behave as I'm describing.  Click-and-hold on the
File menu, the file menu opens.  Drag sideways to the Edit menu, the File menu
closes and the Edit menu opens.  Drag back to the File menu, Edit closes and
File opens.  Drag down to an item, it highlights.  If you have multiple folders
in the toolbar, they should also behave this way.

Comment 10

13 years ago
I have another thing - which might even be another bug. 
If you open a folder in the toolbar, and you move to the next bookmark - which
is NOT a folder, the folder previously opened stays open. 
Expected: it should close (and maybe re-open when moved back), this is the
behaviour I would say is most consistent.
Product: Browser → Seamonkey

Comment 11

11 years ago
Bug https://bugzilla.mozilla.org/show_bug.cgi?id=361027 may be related.
Assignee: bugs → nobody
Status: ASSIGNED → NEW
QA Contact: claudius → bookmarks
Target Milestone: Future → ---

Comment 12

5 years ago
Now on click-and-hold bookmarks folders are dragged, and on single click folder is opened and stay opened until next click, which is consistent, so proposing wontfix here
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA/WONT?]

Comment 13

5 years ago
OK WONTFIX/WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 16 years ago5 years ago
Resolution: --- → WONTFIX

Updated

5 years ago
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA/WONT?] → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.