If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When using wifi, a purchase flow will fail if the device loses connectivity during the buying process.

RESOLVED DUPLICATE of bug 1131395

Status

Marketplace
Payments/Refunds
RESOLVED DUPLICATE of bug 1131395
3 years ago
3 years ago

People

(Reporter: vedolin, Unassigned)

Tracking

x86
Gonk (Firefox OS)
Points:
---

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8562350 [details]
ConnectivityLostDuringPurchase.log

Connectivity: WIFI
SIM used: (Telcel) 55650-62733
Gaia/device: Flame / 2.0
test app used: onlyboku7-51

When using wifi, a purchase flow will fail if the device loses connectivity during the buying process.

Steps to reproduce:

1 - Take note of te current client balance
2 - Have the device connected through wifi.
3 - On the market app, search for a paid app (onlyboku7-51 was used) and press the price button. Immediately after pressing the price button, activate airplane mode. 
4 - Observe the "Loading" message on the "Stage" screen, which will never throw an error
5 - Close the "Stage" screen and observe the error "TRANS_REQUEST_FAILED" displayed.
6 - Deactivate airplane mode and reacquire wifi connectivity.
7 - On the market app, search for a paid app (onlyboku7-51 was used) and start the purchasing flow.
8 - Insert PIN, carrier, phone number and sent purchase-PIN.
9 - Touch "Continuar" (Continue) and immediately activate airplane mode
10 - Observe that the "Confirmando pago" (confirming payment) screen never throws an error message to the user.
11 - Deactivate airplane mode and reacquire connectivity.
12 - Close the "Confirmando pago" screen.
13 - On the market screen, observe the "Payment cancelled" message briefly displayed at the bottom of the screen.
14 - Verify client balance. Observe that despite the confirmation page was never shown, and the "payment cancelled" message displayed, the client was charged the value of the app.

Expected behavior:

The purchasing flow should be interrupted, a "connectivity lost" message displayed and no charge applied.

Actual behavior

The purchasing flow will not inform the user about te problem, and they will be charged even after receiving a "payment cancelled" message.




reproducible: yes
(Reporter)

Comment 1

3 years ago
Created attachment 8562352 [details]
01_LoadingForEver.png
(Reporter)

Comment 2

3 years ago
Created attachment 8562353 [details]
02_TRANS_REQUEST_FAILED.png
(Reporter)

Comment 3

3 years ago
Created attachment 8562355 [details]
03_PIN_STATE_ERROR.png
(Reporter)

Comment 4

3 years ago
Created attachment 8562356 [details]
04_PIN_ENTER_ERROR.png

Comment 5

3 years ago
Inari has the same behavior 

Information: INARI_1.1_DATA_Telcel_Onlyboku

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

3 years ago
Also affects Flame 2.0 on data connectivity.

Updated

3 years ago
Blocks: 987661

Comment 7

3 years ago
If you click on the app after this process, can you install it without purchase? If so, we have recorded the purchase successfully.
Flags: needinfo?(vedolin)
(Reporter)

Comment 8

3 years ago
Yes, it can be installed without purchase.
Flags: needinfo?(vedolin)

Comment 9

3 years ago
In that case we've recorded the purchase successfully so the user has not lost money, if that occurs we'd increase the priority. Bug 1131395 was filed which sounds awfully similar, you are interrupting purchase flow after completing purchase.

There's not a much amount we can do about this. You've interrupted the flow at a particular point. We've recovered gracefully and the payment matches the flow. We could try and make it better, but as noted in bug 1131395 there's probably some platform work. With bug 1131395 open, I don't see any advantage to keeping this one open.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131395
You need to log in before you can comment on or make changes to this bug.