Closed Bug 1131852 Opened 7 years ago Closed 7 years ago

[FxA][Text Selection] User is unable to access Cut/Copy/Paste functionality in Text Fields when signing into a Firefox Account.

Categories

(Firefox OS Graveyard :: FxA, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED DUPLICATE of bug 1127066
blocking-b2g 2.5?
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: Marty, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Description:
The user is not able to copy from or paste to the email address or password fields when signing into or creating a Firefox Account.  The user can access a single caret to move the input cursor, but cannot access the menu to cut/copy/paste

Repro Steps:
1) Update a Flame to 20150210010523
2) Connect the device to a WiFi or Cellular Data network
3) Open the Settings app
4) Navigate to Firefox Accounts
5) Input some text into the Email Address field
6) Long press the text you just entered.

Actual:
The user is unable to select the text in Firefox Account text fields, preventing them from cut/copy/paste functionality.

Expected:
The user is able to select text in Firefox Account text fields, allowing them cut/copy/paste functionality.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150210010523
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 2cb22c058add
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
See attached: video (URL), logcat

-------------------------------------------------

This issue does NOT occur on Flame 2.2.
The user is able to select text in Firefox Account text fields, allowing them cut/copy/paste functionality.

Environmental Variables:
Device: Flame 2.2
Build ID: 20150210002516
Gaia: b30c8e4303595a0fcb5b640d673cf8503b954701
Gecko: 3e9fa4e70a1b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Identifiable functional regression of a supported feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150201170935
Gaia: 740c7c2330d08eb9298597e0455f53d4619bbc1a
Gecko: 231a8c61b49f
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150201174135
Gaia: 740c7c2330d08eb9298597e0455f53d4619bbc1a
Gecko: bcefc7d8d885
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=231a8c61b49f&tochange=bcefc7d8d885

Caused by Bug 950934.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Botond, can you take a look at this please? Looks like the work done on Bug 950934 might have caused this to occur. Maybe we should get this backed out?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(botond)
(In reply to KTucker [:KTucker] from comment #3)
> Looks like the work done on Bug
> 950934 might have caused this to occur. Maybe we should get this backed out?

We are trying very hard not to get bug 950934 backed out :)

It's a feature targeted for 2.2, and several other things depend on it (it's part 3 of a 9-part patch series [1] that we'd like to uplift to 2.2).

It's a major change, so some regressions are expected. We'll fix them as soon as possible.

[1] https://bugzilla.mozilla.org/buglist.cgi?columnlist=bug_status%2Cresolution%2Cshort_desc%2Ccf_last_resolved%2Cstatus_whiteboard&query_format=advanced&status_whiteboard=input-thread-uplift&status_whiteboard_type=allwordssubstr&list_id=11999525
(In reply to Martin Shuman [:Marty] from comment #0)
> 6) Long press the text you just entered.

Long presses for parent-process-apz are implemented in bug 1127066. I have confirmed that with the patches in bug 1127066 make the STR in the bug work.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(botond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1127066
(I do find it interesting that long-tapping on a *content process* (the Settings app) triggers a long-tap in the *parent process*, but I have confirmed with logging that this is the case, so it is indeed bug 1127066 that fixes this.)
That's because the FxA signup stuff is part of the parent process.
You need to log in before you can comment on or make changes to this bug.