[Settings][Feedback] User receives an error message when sending feedback with the Email option deselected.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: dharris, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

Created attachment 8562416 [details]
Send Feedback Logcat

Description:
If the user enters in an email address to allow mozilla to contact the user when sending feedback, and then decides to deselect the email option the user will receive an error message. This error message says it cannot be sent because there is an issue with sending the email, or that it is not valid, but if the user has deselected that option, it should not interfere with sending feedback


Repro Steps:
1) Update a Flame to 20150210010523
2) Open Settings App> Improve Firefox OS
3) Select "Send Mozilla Feedback"> Select Happy, or Sad
4) Type some text in the note area, then select the check box asking about an email address
5) Type an invalid email in the Email Address field
6) Un-select the check box> Tap "Send Feedback"


Actual:
The user is given an error that says the feedback cannot be sent because the email address is wrong on missing, even though the email option has been deselected

Expected:
The feedback is sent and the email is not sent with it.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150210010523
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 2cb22c058add
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/KydXog4ndCo
Qawanted tag is added for branch checks
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
QA Contact: bzumwalt
Issue DOES reproduce in Flame v188-1 Base image, v18D-1 Base image, 2.0, 2.1, and 2.2

When trying to submit feedback after entering message, checking email box, entering email, then unchecking email box, the user is given an error that says the feedback cannot be sent because the email address is wrong on missing.

Device: Flame 2.0 v188-1 Base Image
BuildID: 20141021162107
Gaia: 8c5c956ee6909408e29f375cc7d843a03d92f3d8
Gecko: 60bf345874982e25236ffb80f41e33fdb8ac94f9
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.0 v18D-1 Base Image
Build ID: 20150106124450
Gaia: 79f6218c4f30c2739575c3ab800078c2cda135cb
Gecko: d9d4000dd43a3637345a41d716dc97fdd700d715
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.0
Build ID: 20150210000201
Gaia: 2989f2b2bd12fcc0e9c017d2db766e76a55873b8
Gecko: 2ca6a9e7cb81
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.1
Build ID: 20150210002200
Gaia: 7dd130a312f12c89b2d41948f8557effa56afbf6
Gecko: 2de03dfa9aac
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2
Build ID: 20150210002516
Gaia: b30c8e4303595a0fcb5b640d673cf8503b954701
Gecko: 3e9fa4e70a1b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(pbylenga) → needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I did not have to check and uncheck the email checkbox to get this to occur. I put in a comment and tapped submit and got the email error message. 

Gerry, can you take a look at this? It seems to be forcing the user to put in an email address but it states "Check here to let us contact you from your email" like it is optional.
Flags: needinfo?(gchang)
Hi Jenny, 
This might need your help to determine if "Check here to let us contact you from your email" is optional or the wording is a little confusing.
Flags: needinfo?(gchang) → needinfo?(jelee)

Comment 5

4 years ago
Hi Gerry,

I think the check box is meant for user to choose whether or not to provide email, if not, user can still send feedback, so to me this is a bug. The expected behavior described in the first comment is correct. Thanks!
Flags: needinfo?(jelee)
Hi Arthur, 
Per comment #5, can you help to dispatch this bug?
Flags: needinfo?(arthur.chen)
Add tracking+ flag to have priority working on this.
tracking-b2g: --- → +
Flags: needinfo?(arthur.chen)

Comment 8

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.