Search terms disappear when page doesn't load due in certain circumstances

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
4 years ago
5 days ago

People

(Reporter: arv, Unassigned)

Tracking

({steps-wanted})

35 Branch
ARM
Android
steps-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125221831

Steps to reproduce:

1. Make Firefox temporarily lose network connectivity by switching from wifi to mobile data or vice-versa as in bug 934824.
2. Enter search terms into URL bar, hit enter to search 
3. Reselect the URL bar when the search page fails to load


Actual results:

URL bar contains its previous contents (old URL or search terms)


Expected results:

URL bar contains newly entered search terms from step 2.
I'm not able to reproduce this but maybe I'm not understanding your exact steps to reproduce albeit here's what I'm doing. 

Note I don't have cellular data, so I'm simulating a drop-off as mentioned by disabling my WiFi

  i. Disabled my WiFi
  ii. Entered 'New York' in my address-bar and hit go on my keyboard
  iii. Got a network problem page
  iv. Tapped the address-bar, and I see 'New York' which matches your expected results.

This works for me. Tested on Firefox 35 through 38 on my Nexus 6 (5.0.2)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: steps-wanted
OS: Linux → Android
Hardware: x86_64 → ARM
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
@aaronmt Unfortunately just disabling wifi won't replicate the bug.  You have to reproduce my steps exactly, starting with a loss of connectivity *only in Firefox* as described in bug 934824 when switching between wifi and mobile data.  I experience bug 934824 frequently, and so this disappearing search term bug affects me as well.  It is possible that when bug 934824 is fixed, this issue will be fundamentally fixed as well, but it strikes me that once I type in search terms, nothing that happens following that should cause them to disappear, and so I believe this is likely a separate issue.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Hi, the issue is still reproducible with latest Nightly? Tested with Samsung Galaxy Note 8(Android 8.0) and couldn't reproduce the issue.
Flags: needinfo?(arv)
(Reporter)

Comment 4

7 days ago
I can no longer reproduce following my original steps on the latest release version, so I would say this is fixed.
Flags: needinfo?(arv)

Comment 5

5 days ago
Based on Comment 4, I am closing this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago5 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.