two newlines added to text copied from message body

VERIFIED DUPLICATE of bug 98572

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 98572
16 years ago
10 years ago

People

(Reporter: Bron Gondwana, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112009

I'm trying to copy text from an email message I'm in the middle of replying to,
so I select the text "Firstname Lastname" and press CTRL-C.

I then go to any other application (Notepad works) and paste, and get

"Firstname Lastname

"

Reproducible: Always
Steps to Reproduce:
1a. Open a compose window in Mozilla and paste in some text from a message that
has quoted reply text in it, OR
1b. Hit reply on any message in Mozilla.
2. copy text from part of the text that's already there (text that you've typed
in doesn't suffer from this
3. paste into another application.

Actual Results:  When I typed in text at the bottom of the message "Firstname
Lastname", then copying it gave "Firstname Lastname" in the result, but when I
copied from the section I was quoting, it pasted as "Firstname Lastname

"

Expected Results:  Pasted as "Firstname Lastname", since there were no endlines
in the text I copied.

In general, I've noticed that the compose windows trys to autoformat the quoting
(the blue line down the left hand side) in a 'clever' way, which tends to just
be annoying and prone to mess up, especially if there's any ASCII-art type
layout of the quoted text (i.e. psql database results).

Comment 1

16 years ago
Bug 98572 initially states one extra linefeed is added, but i always see two as
well, under the same conditions: when copying any kind of pre-formatted text.
Resolving as dup.

*** This bug has been marked as a duplicate of 98572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified as dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.