Cursor position becomes corrupt in TextArea

RESOLVED WONTFIX

Status

()

Core
Editor
RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: Gili, Assigned: jhp (no longer active))

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.6+) Gecko/20011130
BuildID:    2001113019

Enter data in any TextArea and oyu will notice that as more characters are added
over  time, the cursor keeps on moving more and more to the left until
eventually you're typing characters and they pop up on the RIGHT of the cursor,
not on its left.

Try playing around with textareas, selecting the text, moving around until you
see the problem. I'm seeing this problem right now as I'm entering this report
in Bugzilla helper.

PS: I'm pretty sure this problem has to do with font-resizing.. I hit CTRL-+ to
make the font look bigger and (as a result) the cursor goes heywire. I'm pretty
sure this doesn't happen on the default font size.

Reproducible: Didn't try
editor
Assignee: pchen → kin
Component: XP Apps → Editor: Core
QA Contact: sairuh → sujay

Comment 2

17 years ago
We just fixed this one.

Thanks!

*** This bug has been marked as a duplicate of 107905 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

16 years ago
Issue is back in build 2001122111.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

16 years ago
We had to back out the fix because it causes problems.
Assignee: kin → pedemont
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

16 years ago
Any progress on this issue? It's quite annoying.

Comment 7

16 years ago
*** Bug 125616 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
*** Bug 180665 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
I was going to report this bug, but here it is already.

It's still very much alive in version 1.2.1, and likely 1.3a as well.  It's
something I've noticed for a very long time, and it's extremely annoying.

Are there any plans to fix this in the near future?

Comment 10

15 years ago
Have you tried the new font stuff from Innotek?

It fixes this problem.

Comment 11

15 years ago
This is yet another bug caused by OS/2's font rounding.

Innotek's font engine fixes this.
Status: NEW → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.