Mail Client window resized to extremely width when calendar activated

RESOLVED WORKSFORME

Status

Calendar
Lightning: SeaMonkey Integration
--
major
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: nas, Unassigned)

Tracking

Lightning 3.7
x86_64
Linux

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32
Build ID: 20150121015628

Steps to reproduce:

Using Seamonkey v 2.32 (from fedora repositories) - Build identifier: 20150121015628
Installed Lightning v 3.7b1 add-on (for calendar).

I opened Mail Client, and from upper menu (File |  Edit | ... | Events and Tasks | ...) I selected Calendar.



Actual results:

Then the window lost it's rounded up left corner, and it was like the width of the window become so large that was out of screen. I moved the window from the right to the left 8 - 10 times so I suppose it has a width about 20.000 pixels
Couldn't maximize the window, and some of the tries I did it made all windows in my Mate desktop appear immediately one after another.

The package "marco" crashed and I had a report from my Fedora 

CPU went high.

Tried to take screenshots but I couldn't. If you need I could send you pictures / video of my screen using my camera


Expected results:

Mail Client window shouldn't resize, and calendar should appear normally
(Reporter)

Updated

3 years ago
Summary: Mail Client window resized itself and all → Mail Client window resized to extremely width when calendar activated
(Reporter)

Updated

3 years ago
Severity: normal → major
Component: General → Lightning: SeaMonkey Integration
OS: All → Linux
Hardware: All → x86_64
Duplicate of this bug: 1131947

Comment 2

3 years ago
You're eventually expiriencing bug 1081534, which is fixed for 3.9 and newer. Do you have calendar.icaljs enabled? If so, does it work again if you disable that?
(Reporter)

Comment 3

3 years ago
In about:config, calendar.icaljs was false. I did the steps and I got the problem. I changed it to true, and same problem happened again.

It doesn't work enabled or disabled.

Thank you for the tip anyway!

Comment 4

3 years ago
Leave it disabled, as icaljs is broken in 3.8. You mentioned above you installed SM from Fedora package manger. Did you install Lightning from the same source or from AMO? Mixing installations may cause effects like this.
(Reporter)

Comment 5

3 years ago
I didn't install Lightning from Fedora repositories, since it exists only as thunderbird extension, and it is 3.3.5 version.

Version v 3.7b1 of Lightning appears compatible in: https://addons.mozilla.org/en-us/seamonkey/addon/lightning/versions/

Comment 6

3 years ago
In that case, SM is eventually not binary compatible wirh Lightning. Can you please download SM from the website and check whether Lightning works for you with that and report back?

Hopefully, we can get rid of the binary compatibility mess with Lighrnng 4.0

Comment 7

3 years ago
Fedora provides its own Lightning package: https://admin.fedoraproject.org/pkgdb/package/thunderbird-lightning/

Could you please retest using either both Thunderbird and Lightning from Fedora or both from mozilla.org?
Flags: needinfo?(dev)
(Reporter)

Comment 8

3 years ago
@Stefan Sitter:

I installed Lightning it using Fedora Repositories, but didn't appear in Seamonkey.

I installed Thunderbird using repositories, and it seems it works fine with lightning.

@MakeMyDay:

I downloaded from seamonkey-project.org and installed Seamonkey 2.33, and installed from:
https://addons.mozilla.org/en-us/seamonkey/addon/lightning/versions/

the Lightning Version 3.8b2. The problem still exists.

I made one more test which seems to resolve my problem:

I run seamonkey 2.32 as different user on my pc, and installed Lightning v 3.7b1 on that. It seems it works fine, without the problems I have in my seamonkey.

Is there any way I could totally clean-up all calendar settings/ data in my profile and see if I continue having problems ? I don't care about the data.
Flags: needinfo?(dev)

Comment 9

3 years ago
You can simply create a new profile. 

What further extensions do you use? Can try to disable all of them if any except of Lightning to see if the issue still persits? If not, re-enable them one by one to identify the suspicious one.
(Reporter)

Comment 10

3 years ago
I use this profile for more than 5 years(maybe 10?) and I wouldn't like to create a new one. If that will be the only solution, I will do it...

I disabled all other extensions, and the problem still exists. I looked my profile directory and about:config for any lightning settings that I could remove/ edit, without any luck.

Any other way to have some debug output so I can investigate / provide it here?

Comment 11

3 years ago
Please simply create a new profile for testing first - if the issue still persists, there's no need to abandon the prvious one. Please report your result to bug 1144285 - I close this one as a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1144285

Comment 12

3 years ago
This is not a duplicate of bug 1144285, so I'm reopening this again. Sorry for dupping this.

This is a problem with your profile as you mentioned above. If creating a clean profile resolves the problem for you, this is the recommended way to go. Just make sure to leave calendar.icaljs disabled at least until you're on SM 2.34 or above.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 13

3 years ago
I'm running SM/LTG on two linux systems, currently SM 2.33.1 with LTG 3.8b2. One is Ubuntu 14.04 LTS 64 (SM 64 bit downloaded from the Mozilla website, untarred and installed manually), the other one is Ubuntu 14.04 LTS 32 bit (SM 32 bit from the ubuntuzilla repository, updated automatically). On both of the systems, I didn't experience one of the described issues in this bug or the other one, bug 1144285.

So, I agree with MakeMyDay's advice to test with a new and clean profile first.

As you are using a 64 bit linux distribution, you should make sure to use the right lightning binary. On SM 64 bit, you will need the linghtning linux-x86_64 binary. You wrote: "I installed Lightning it using Fedora Repositories, but didn't appear in Seamonkey.". That leads to the conclusion that you probably tried to install the lightning linux-i686 binary.
We discussed this via IRC, it was the noexec flag on the partition. Please reopen if there are other related issues.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

3 years ago
thank you for your help. Indeed in my case the noexec in profile's filesystem was the problem.

@Carsten: I installed the x86_64 version of thunderbird-lightning 3.3-5.fc21 - just checked right now.
Hello,

this problem appears here, even with new profile.
It did with 2.35 and bundled lightning 4.0, it does again with 2.38 and bundled lightning 4.3.
Does not happen when using lightning extension downloaded from the network.
You need to log in before you can comment on or make changes to this bug.