Closed Bug 1131954 Opened 5 years ago Closed 3 years ago

Improve the performance of SamplerStackFramePrintfRAII

Categories

(Core :: Gecko Profiler, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1339897

People

(Reporter: jrmuizel, Unassigned)

Details

Attachments

(1 file)

Writes everything into the single buffer instead of copying twice. Also removes the first printf and copies directly.

Some of the printf code was showing up in profiles. It was probably the printf that's left but we might as well make these functions as tight as possible.
Attachment #8562625 - Flags: review?(bgirard)
Comment on attachment 8562625 [details] [diff] [review]
Improve the performance of SamplerStackFramePrintfRAII

Review of attachment 8562625 [details] [diff] [review]:
-----------------------------------------------------------------

This patch is bad. Let's use the preprocessor to do the concat for us since the input to this function is always a string literal.
Attachment #8562625 - Flags: review?(bgirard) → review-
SamplerStackFramePrintfRAII was removed in bug 1339897
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1339897
You need to log in before you can comment on or make changes to this bug.