mozilla contact emails don't work if they aren't registered users

VERIFIED FIXED in 2015-03-10

Status

Marketplace
Developer Pages
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: eviljeff, Assigned: ngoke, NeedInfo)

Tracking

Avenir
2015-03-10
x86_64
Windows 7
Points:
---

Details

(Reporter)

Description

3 years ago
(noticed during some testing recently)

The Mozilla contact field in the apps edit page is a free text field for email addresses.  However, it appears that any email address entered which doesn't correspond to a registered user doesn't receive any email.  I'm guessing this happened post the commbadge switch on in Q3/Q4.

Two possible fixes:
A) revert to previous behaviour and email every email address in the field
B) validate the field to prevent unregistered email addresses being entered; (and in the model change the attribute from text to a foreign key to many User)
(Reporter)

Comment 1

3 years ago
NI for the two affected parties (biz dev and dev rel) -
workaround is either registering on Marketplace with those addresses or I ask IT to run some sql on the database to change the mailing list you use (apps-bd@ ; techeven@) to a registered user.
Flags: needinfo?(dchinniah)
Flags: needinfo?(dcallahan)
I just joined DevRel in the past few months, so I don't have a ton of context for our work on FxOS apps / marketplace... could you explain what sort of emails get sent and how often? That will guide our decision on keeping things on the main list (techevan@), or setting up a separate registered user.
(Reporter)

Comment 3

3 years ago
(In reply to Dan Callahan [:callahad] from comment #2)
> I just joined DevRel in the past few months, so I don't have a ton of
> context for our work on FxOS apps / marketplace... could you explain what
> sort of emails get sent and how often? That will guide our decision on
> keeping things on the main list (techevan@), or setting up a separate
> registered user.

You get copied on all correspondence between the developer, reviewer, and Marketplace itself.  So for some apps it will be 1 email on approval; and others there may be a few back and forth. Packaged apps will result in this kind of email correspondence for each version.  The most extreme will probably be a hosted app that has an unreliable server and goes up and down every few days - I've seen apps with 50+ of these kind of messages.
In general within the field, BD folks enter themselves rather than an alias like apps-bd@

However we should likely cover the alias angle too for maybe those that don't have specific owners.

Andrew - Have you asked IT to have the mailing alias added as a registered user?
Flags: needinfo?(awilliamson)
Also can you maybe please cross-reference these emails and confirm which ARE NOT registered users:

Didem Ersoz <dersoz@mozilla.com>, Mano Balasubramaniam <mbalasubramaniam@mozilla.com>, Oliver Duric <oduric@mozilla.com>, Silvio Chiba <schiba@mozilla.com>, Desigan Chinniah <dchinniah@mozilla.com>, APPS BD

Harald Kirschner <hkirschner@mozilla.com>, Nick Desaulniers <ndesaulniers@mozilla.com>, Louis Stowasser <lstowasser@mozilla.com>, Bill Walker <bwalker@mozilla.com>, APPS PARTNER ENGINEERING
Flags: needinfo?(dchinniah)
(Reporter)

Comment 6

3 years ago
I wouldn't have thought IT can add the apps-bd@ list - someone with list access needs to create a FirefoxAccount with that email, and confirm its valid with the link in the confirmation email.  Once that's done its just a matter of logging into Marketplace once with it.

Re: the emails for your team members - they all appear to be registered users.
Flags: needinfo?(awilliamson)
(In reply to Andrew Williamson [:eviljeff] from comment #6)
> I wouldn't have thought IT can add the apps-bd@ list - someone with list
> access needs to create a FirefoxAccount with that email, and confirm its
> valid with the link in the confirmation email.  Once that's done its just a
> matter of logging into Marketplace once with it.

This address should now be verified. Can you confirm?


> 
> Re: the emails for your team members - they all appear to be registered
> users.

Great.
(Reporter)

Comment 8

3 years ago
(In reply to Desigan Chinniah [:cyberdees] [:dees] [London - GMT] from comment #7)
> (In reply to Andrew Williamson [:eviljeff] from comment #6)
> > I wouldn't have thought IT can add the apps-bd@ list - someone with list
> > access needs to create a FirefoxAccount with that email, and confirm its
> > valid with the link in the confirmation email.  Once that's done its just a
> > matter of logging into Marketplace once with it.
> 
> This address should now be verified. Can you confirm?

Confirmed.  (In theory) that should be fixed for you now, though if you don't receive any Marketplace emails to that address in the next few days something else is afoot.

Updated

3 years ago
Priority: -- → P2

Updated

3 years ago
Assignee: nobody → kngo
Priority: P2 → P1
(Assignee)

Comment 10

3 years ago
STR:

1. In the Developer Hub, set the Mozilla contact of an app to an email. The email must not be registered as a user.
2. Do a reviewer action on the app (e.g, approve, reject, reviewer comment).

Expected:

The Mozilla contact should get an email. However, the Mozilla contact will not be able to Reply-To the email unless they create an account.

Actual:

The Mozilla contact does not get any email.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Target Milestone: --- → 2015-03-10

Comment 11

3 years ago
When trying to approving an app to which I have added a mozilla contact the approving fails with an "Oops.." error. I think this is related to this fix because approving other apps (with no mozilla contact added) worked fine.
Please view this screencast: http://screencast.com/t/TY1sKNsfv
Reopening bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 12

3 years ago
http://sentry.dmz.phx1.mozilla.com/marketplace-stage/marketplace-stage/group/25645/
'TemplateNotFound: comm/emails/{'nonuser_mozilla_contact': True}.html'
(Assignee)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

3 years ago
Thanks Andrew for the quick fix.

Comment 15

3 years ago
Approving works correctly now, also the email is sent to the mozilla contact: http://screencast.com/t/BxLNNzSB
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.