Scrollbar should be on the left for RTL websites

RESOLVED DUPLICATE of bug 221396

Status

()

RESOLVED DUPLICATE of bug 221396
4 years ago
4 years ago

People

(Reporter: martijn, Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8562875 [details]
Right-to-left HTML document

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

I created a small html file with in the html element attributes `dir=rtl` and `lang=ar-ae`, so there's no doubt about which language the browser is going to have to present to the user. Then I just plunked in some Arabic lorem ipsum-like text.


Actual results:

The Arabic text displays fine, and the page renders in right-to-left mode. But the scrollbar is still on the right side.


Expected results:

In right-to-left languages, people tend to not only read right-to-left, but much of their thinking works that way. Left-to-right seems so natural to us, but to Arabic and Hebrew folks, it's reversed. More of less.

So, the scrollbar needs to go to the left for pages with `dir=rtl`. Internet Explorer does this absolutely fine.

This should go for every scrollbar that is still hasn't somehow been reset to left-ro-right reading. So it should include textareas, dropdowns, elements with scrolling overflowing content, etc.

Comment 1

4 years ago
You should set layout.scrollbar.side to 1 in about:config if you want to place the scrollbar based on the document/content’s direction.
(Reporter)

Comment 2

4 years ago
It's not a problem with only my scrollbar, it's a problem with everyone's scrollbar. If I build a website in Arabic, I can't go and tell every one of my visitor to poke in their about:config in order to get the the scrollbar on my site on the right spot.

This issue should be fixed in Firefox.

Comment 3

4 years ago
This is dup of Bug 221396. and that is RESOLVED WONTFIX.
(Reporter)

Comment 4

4 years ago
Why would you refuse to fix it? It's a real problem for Arabic and Hebrew people.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 221396
(Reporter)

Comment 6

4 years ago
That issue is marked as fixed, but the issue is NOT fixed at all.

Unmark as dupe, or unmark as resolved please.
You need to log in before you can comment on or make changes to this bug.