Intermittent test_SeekTwice_mp4.html | application crashed [@ mozilla::MP4Reader::Update(mp4_demuxer::TrackType)]

RESOLVED INVALID

Status

()

Core
Audio/Video
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
07:06:11 INFO - 2270 INFO SourceBuffer buffered ranges grew from TimeRanges: [0, 4.005)[4.805, 9.61) to TimeRanges: [0, 4.005)[4.805, 10.01)
07:06:11 INFO - 2271 INFO TEST-PASS | dom/media/mediasource/test/test_SeekTwice_mp4.html | Got seeking event
07:06:11 INFO - 2272 INFO TEST-PASS | dom/media/mediasource/test/test_SeekTwice_mp4.html | Got seeked event
07:06:11 INFO - 2273 INFO TEST-PASS | dom/media/mediasource/test/test_SeekTwice_mp4.html | Time >= 6
07:06:11 INFO - 2274 ERROR TEST-UNEXPECTED-FAIL | dom/media/mediasource/test/test_SeekTwice_mp4.html | application terminated with exit code 1
07:06:11 INFO - runtests.py | Application ran for: 0:10:45.010000
07:06:11 INFO - zombiecheck | Reading PID log: c:\users\cltbld\appdata\local\temp\tmpm92mrapidlog
07:06:11 INFO - ==> process 3052 launched child process 716 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=3052.15580c40.2076807629 "c:\users\cltbld\appdata\local\temp\tmp8kwhxu.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 3052 "\\.\pipe\gecko-crash-server-pipe.3052" plugin)
07:06:11 INFO - mozcrash Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-win32-pgo/1423650625/firefox-38.0a1.en-US.win32.crashreporter-symbols.zip
07:06:20 INFO - mozcrash Saved minidump as C:\slave\test\build\blobber_upload_dir\a17c0586-581a-47d2-a6da-25e8c0fc7e2c.dmp
07:06:20 INFO - mozcrash Saved app info as C:\slave\test\build\blobber_upload_dir\a17c0586-581a-47d2-a6da-25e8c0fc7e2c.extra
07:06:20 WARNING - PROCESS-CRASH | dom/media/mediasource/test/test_SeekTwice_mp4.html | application crashed [@ mozilla::MP4Reader::Update(mp4_demuxer::TrackType)]
07:06:20 INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmp8kwhxu.mozrunner\minidumps\a17c0586-581a-47d2-a6da-25e8c0fc7e2c.dmp
07:06:20 INFO - Operating system: Windows NT
07:06:20 INFO - 6.1.7601 Service Pack 1
07:06:20 INFO - CPU: x86
07:06:20 INFO - GenuineIntel family 6 model 30 stepping 5
07:06:20 INFO - 8 CPUs
07:06:20 INFO - Crash reason: EXCEPTION_ACCESS_VIOLATION_READ
07:06:20 INFO - Crash address: 0x58
07:06:20 INFO - Thread 74 (crashed)
07:06:20 INFO - 0 xul.dll!mozilla::MP4Reader::Update(mp4_demuxer::TrackType) [MP4Reader.cpp:0b041d1c5307 : 721 + 0xb]
07:06:20 INFO - eip = 0x660d4fb0 esp = 0x0db4f878 ebp = 0x0db4f8a4 ebx = 0x14046000
07:06:20 INFO - esi = 0x00000000 edi = 0x14046160 eax = 0x00000000 ecx = 0x19bbca10
07:06:20 INFO - edx = 0x00500220 efl = 0x00010246
07:06:20 INFO - Found by: given as instruction pointer in context
07:06:20 INFO - 1 xul.dll!nsRunnableMethodImpl<void ( mozilla::DataStorage::*)(char const *),char const *,1>::Run() [nsThreadUtils.h:0b041d1c5307 : 361 + 0x5]
07:06:20 INFO - eip = 0x655571a4 esp = 0x0db4f8ac ebp = 0x0db4f8b0
07:06:20 INFO - Found by: call frame info
07:06:20 INFO - 2 xul.dll!mozilla::MediaTaskQueue::Runner::Run() [MediaTaskQueue.cpp:0b041d1c5307 : 230 + 0x3]
07:06:20 INFO - eip = 0x6606fef5 esp = 0x0db4f8b8 ebp = 0x0db4f8d4
07:06:20 INFO - Found by: call frame info
07:06:20 INFO - 3 xul.dll!nsThreadPool::Run() [nsThreadPool.cpp:0b041d1c5307 : 225 + 0x5]
07:06:20 INFO - eip = 0x651624f8 esp = 0x0db4f8dc ebp = 0x0db4f904
07:06:20 INFO - Found by: call frame info
07:06:20 INFO - 4 xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:0b041d1c5307 : 855 + 0x5]
07:06:20 INFO - eip = 0x6540b956 esp = 0x0db4f90c ebp = 0x0db4fa0c
07:06:20 INFO - Found by: call frame info
07:06:20 INFO - 5 xul.dll!NS_ProcessNextEvent(nsIThread *,bool) [nsThreadUtils.cpp:0b041d1c5307 : 265 + 0xa]
07:06:20 INFO - eip = 0x653c2636 esp = 0x0db4fa14 ebp = 0x0db4fa28
07:06:20 INFO - Found by: call frame info
07:06:20 INFO - 6 xul.dll!mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) [MessagePump.cpp:0b041d1c5307 : 368 + 0x9]
07:06:20 INFO - eip = 0x653c25c7 esp = 0x0db4fa30 ebp = 0x0db4fa4c
07:06:20 INFO - Found by: call frame info
07:06:20 INFO - 7 xul.dll!MessageLoop::RunHandler() [message_loop.cc:0b041d1c5307 : 226 + 0x7]
07:06:20 INFO - eip = 0x6540acfc esp = 0x0db4fa54 ebp = 0x0db4fa84
07:06:20 INFO - Found by: call frame info
07:06:20 INFO - 8 xul.dll!MessageLoop::Run() [message_loop.cc:0b041d1c5307 : 200 + 0x6]
07:06:20 INFO - eip = 0x6540ab06 esp = 0x0db4fa8c ebp = 0x0db4faa4
07:06:20 INFO - Found by: call frame info
07:06:20 INFO - 9 xul.dll!nsThread::ThreadFunc(void *) [nsThread.cpp:0b041d1c5307 : 356 + 0x6]
07:06:20 INFO - eip = 0x6513ca23 esp = 0x0db4faac ebp = 0x0db4fabc
07:06:20 INFO - Found by: call frame info
07:06:20 INFO - 10 nss3.dll!_PR_NativeRunThread [pruthr.c:0b041d1c5307 : 397 + 0x5]
07:06:20 INFO - eip = 0x68094763 esp = 0x0db4fac4 ebp = 0x0db4fadc
07:06:20 INFO - Found by: call frame info
Comment hidden (Treeherder Robot)
Looks like this is crashing here:

https://hg.mozilla.org/integration/fx-team/file/0b041d1c5307/dom/media/fmp4/MP4Reader.cpp#l721

And the crashing push is the actually the one that introduced that change: https://treeherder.mozilla.org/#/jobs?repo=fx-team&revision=0b041d1c5307

So it seems pretty clear that the code there is wrong. Mike, do you know what's going on, or should we back out?
Flags: needinfo?(miket)
Blocks: 1125340
Keywords: regression
Yeah, that was my bad--that was backed out by Tomcat earlier today. See https://bugzilla.mozilla.org/show_bug.cgi?id=1125340#c32.

The updated patch has been reviewed and is awaiting check in (1125340-9.patch from Bug 1125340).
Oops, ni? to ask how to resolve this. Fixed? Invalid?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

4 years ago
Sorry about that, my fault.
Flags: needinfo?(bobbyholley)
Keywords: crash, intermittent-failure, regression
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.