Closed Bug 1132176 Opened 5 years ago Closed 5 years ago

[Camera][Shinano] Enable 4K video recording

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox38 fixed)

RESOLVED FIXED
Tracking Status
firefox38 --- fixed

People

(Reporter: mikeh, Assigned: mikeh)

References

Details

Attachments

(2 files, 1 obsolete file)

CameraParameters::getSupportedVideoSizes() returns a supported 2160x3840, but no profile matching this resolution exists in media_profiles.xml. That file only lists a '1080p' profile; it does not even include a 'high' profile.

There is also this:
http://stackoverflow.com/questions/28294041/android-sony-z3-4k-video-recording

...which seems to not be the case in our case.
Once this is working, we'll probably want to enable the recorder-profiles settings-menu in the Camera app:

https://github.com/mozilla-b2g/gaia/blob/master/apps/camera/js/config/config.js#L364
Confirmed that the media_profiles.xml file on a Shinano flashed with Android 4.4.4 also does not contain any references to 4K video recording, even though the vendor's Camera app clearly supports it.
Further to comment 2, media_profiles.xml does include a definition for the h264 codec, which is listed with:
- maxFrameWidth="3840"
- maxFrameHeight="2160"
In addition to the rest of the patches required to get the camera working on Shinano, this patch enables the 4K (UHD) profile.

Note that with this patch, the Camera app will use this profile by default, and a ~9-second video will consume ~70MB of storage space. :)
Assignee: nobody → mhabicher
Status: NEW → ASSIGNED
Attachment #8563598 - Flags: review?(mwu)
I think we want a PR here for device-shinano that first imports media_profiles.xml and installs it via PRODUCT_COPY_FILES, and then this patch/commit which adds 4k support.
Attachment #8563598 - Attachment is obsolete: true
Attachment #8563598 - Flags: review?(mwu)
Attachment #8563651 - Flags: review?(mwu)
Comment on attachment 8563651 [details] [review]
[PR] Add support for 4K UHD video recording

No 4k at 60fps? :)
Attachment #8563651 - Flags: review?(mwu) → review+
(In reply to Michael Wu [:mwu] from comment #8)

> No 4k at 60fps? :)

I'll get right on that. ;)
https://github.com/mozilla-b2g/device-shinano/commit/5beea51b69a01c31d6684f37e770536e6136b986
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
It turns out we're missing a piece in Gecko as well. Patch forthcoming.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8564204 - Flags: feedback?(lissyx+mozillians)
Comment on attachment 8564204 [details] [diff] [review]
Add '4kuhd' token to Gecko, v1

Review of attachment 8564204 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8564204 - Flags: review?(aosmond) → review+
Comment on attachment 8564204 [details] [diff] [review]
Add '4kuhd' token to Gecko, v1

As said on IRC, with this applied I see:
 - 4kuhd 3840x2160
 - default 3840x2160
 - high 3840x2160
 - 1080p 1920x1080
etc.
Attachment #8564204 - Flags: feedback?(lissyx+mozillians) → feedback+
https://hg.mozilla.org/mozilla-central/rev/0841363f5b91
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.