Closed Bug 1132212 Opened 5 years ago Closed 5 years ago

TSan: data race netwerk/protocol/nsHttpTransaction.cpp:605 Caps

Categories

(Core :: Networking: HTTP, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox38 --- fixed

People

(Reporter: froydnj, Assigned: mcmanus)

References

(Blocks 1 open bug)

Details

(Whiteboard: [tsan])

Attachments

(2 files)

Attached file http-race.txt
[cribbing from decoder's script, hopefully he won't mind]

The attached logfile shows a thread/data race detected by TSan (ThreadSanitizer).

Typically, races reported by TSan are not false positives, but it is possible that the race is benign. Even in this case though, we should try to come up with a fix unless this would cause unacceptable performance issues. Also note that seemingly benign races can possibly be harmful (also depending on the compiler and the architecture) [1].

If the bug cannot be fixed, then this bug should be used to either make a compile-time annotation for blacklisting or add an entry to the runtime blacklist.

[1] http://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
Thanks Nathan. I think I can figure this out - but if you have a cset for that build it would be helpful.. some line numbers have changed a bit I think.
never mind about the cset - its obvious what the cause is.. and its intentional (which makes it easy to identify at least!). Though based on this I'll look at changing it.
Assignee: nobody → mcmanus
Status: NEW → ASSIGNED
steve, can you help with this review? Its changing code I'm pretty sure we cooked up together.

you'd have a try run if try wasn't CLOSED TREE :(
Comment on attachment 8563574 [details] [diff] [review]
nshttptransction.cpp dont play with data race fire

Review of attachment 8563574 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, yes. Looks sane to me. r=me pending try :)
Attachment #8563574 - Flags: review?(sworkman) → review+
https://hg.mozilla.org/mozilla-central/rev/216e9a560a66
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.