[RTL][Calendar] Accounts are incorrectly truncated.

VERIFIED FIXED in Firefox OS v2.2

Status

P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: mmedeiros)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8563062 [details]
Accounts.png

Description:
On Calendar Settings screen, the added accounts are truncated incorrectly. 

Repro Steps:
1) Update a Flame device to BuildID: 
2) Set the device language in Arabic under Settings > Language.
3) Select the drawer icon, and the settings icon.
4) Select "Add account", and add a valid calendar account.
5) Return to the Calendar Settings screen, and observed the added account.

Actual:
Truncation occurs at the beginning of the section, such as "Google" or "Yahoo!".
  
Expected:
Truncation occurs at the end of the section, so the email address is truncated.
 

Device: Flame Master (319mb, full flash)
Build ID: 20150211010216
Gaia: 8c7865486a1b11076b849bbf8f7fccbaffbfafe7
Gecko: ee093ca70666
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Device: Flame 2.2 (319mb, full flash)
Build ID: 20150211002505
Gaia: 943be6fd146017dcd9d4c9d1027be1e43bad13eb
Gecko: e614443583e7
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 5/5
See attached: screenshot
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
triage: we have a number of bugs like this, see bug 1126587 comment 15 for some guidance on proper treatment.
feature-b2g: --- → 2.2+
Priority: -- → P2
See Also: → bug 1126587
(Assignee)

Updated

4 years ago
Assignee: nobody → mmedeiros
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2.2 S6 (20feb)
Created attachment 8563776 [details] [review]
[gaia] millermedeiros:1132238-rtl-account-truncated > mozilla-b2g:master
(Assignee)

Comment 3

4 years ago
Comment on attachment 8563776 [details] [review]
[gaia] millermedeiros:1132238-rtl-account-truncated > mozilla-b2g:master

added `[dir="auto"]` for account name on "drawer" and "advanced settings".
Attachment #8563776 - Flags: review?(gaye)
Comment on attachment 8563776 [details] [review]
[gaia] millermedeiros:1132238-rtl-account-truncated > mozilla-b2g:master

I just r+'d this patch on another bug.
Attachment #8563776 - Flags: review?(gaye) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
status-b2g-master: affected → fixed
(Assignee)

Comment 6

4 years ago
Comment on attachment 8563776 [details] [review]
[gaia] millermedeiros:1132238-rtl-account-truncated > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: RTL users might not be able to identify between 2 accounts since it truncates the user name from the email address
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): low risk
[String changes made]: none
Attachment #8563776 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8563776 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/fee32b6723207177535d20604724ce3711f61620
status-b2g-v2.2: affected → fixed
Target Milestone: 2.2 S6 (20feb) → 2.2 S7 (6mar)
(Reporter)

Comment 8

4 years ago
This issue is verified fixed on Flame Master and 2.2.

Result: Truncation occurs at the end of the section, so the email address is truncated.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150225010244
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: 0a8b3b67715a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150225002505
Gaia: ca64f2fe145909f31af266b1730874051ba76c78
Gecko: 16804008c29f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15912/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.