Changing from Free to Paid app fails with TypeError: can't convert undefined to object devreg-min.js:10

VERIFIED FIXED in 2015-02-17

Status

Marketplace
Developer Pages
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: krupa, Assigned: scolville)

Tracking

({regression})

2015-02-17
regression
Points:
---

Details

(URL)

(Reporter)

Description

3 years ago
Found by Vedolin of Intertek


steps to reproduce:
1. Load https://marketplace-dev.allizom.org/developers/app/test-app-turtle4495/payments/
2. Try to change from Free to Paid


actual behavior:
Changing from Free to Paid app fails with TypeError: can't convert undefined to object devreg-min.js:10
Assignee: nobody → scolville
I'll investigate this and find out what the cause is.
PR: https://github.com/mozilla/zamboni/pull/2909
Status: NEW → ASSIGNED
Priority: -- → P1
https://github.com/mozilla/zamboni/commit/3e32ee9cecdb914eacd43b1e8fb4e1d7279bb91e
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 4

3 years ago
Verified as fixed on MP-dev on FF38 (Win 7).
Postfix screecast http://screencast.com/t/oj3fjRFIgV5p 
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.