Themes that are rejected then edited are not accessible through the Interactive Theme Queue link.

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Pam, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8563159 [details]
reviewqueue.gif

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

When a design that has been rejected is edited by the designer and resubmitted, it's placed in the Updates tab (which it should be) but for some reason when you click on the Interactive Theme Queue link those rejected designs do not display in order to be re-reviewed. The only way to access them is to click on the title of each design and from there they can be re-evaluated.




Expected results:

The designs that have been rejected and edited should be accessible through the Interactive Theme Queue link.

I've attached an image with various print screens showing the Updates tab with three valid updates (outlined in purple) and then the Interactive Theme Queue page showing that only those three designs are accessible while the rejected/edited designs are not. The blue outlined design is my test design that was rejected and then edited. I've left the test design online in case it's needed for further testing. The other three rejected designs seem to have been deleted by the designer and are not accessible.
I'm not completely sure, but I wonder if that's not the way it should be?

A theme that has already been rejected once needs more scrutiny before approving it. On the contrary, an already approved theme maybe needs less attention.

As you can't see the review history of each theme in the interactive theme queue, maybe it's not a good idea to have rejected themes in it?

Let's see what Kris and Jorge have to say on this matter.
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(jorge)
I think this is a question for Amy.
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(jorge)
Flags: needinfo?(atsay)

Comment 3

3 years ago
Hi Pam, I see what you mean. However, Mathieu has a point--it is useful to see the review history for a theme that has been rejected and edited. That way you know why it was rejected in the first place and whether the problem was fixed. Unless there are other reasons why this isn't ok, I'm going to mark it "resolved." Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(atsay)
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.