Double-click in search bar does not work

RESOLVED WORKSFORME

Status

()

Firefox
Search
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Herre de Jonge, Unassigned)

Tracking

35 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

Double-click in the search box in order to select a word.


Actual results:

The (new) search engine select box briefly flashes.


Expected results:

The word that was double-clicked should be selected. Also continuing to drag should select additional words.

It used to work, but stopped working a few releases back. I think with the introduction of the new search engine selection drop down. Also it's the only edit box where this happens. The address bar and text fields on a form work as expected.

Comment 1

3 years ago
Works for me on GNU/Linux with firefox-35.0.ru.linux64 and 2015-02-18-03-02-28-mozilla-central-firefox-38.0a1.ru.linux-x86_64, both in the toolbar and on the new tab page.

Maybe related: bug 1128345, bug 1094041.
(Reporter)

Comment 2

3 years ago
It also works for me under Windows (FF v35.0.1), but not Mac OSX (which is my main OS).

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

3 years ago
I can confirm this on 35.0.1 on Mac OS X 10.6, and also just upgraded to 36.0.4 and it's still there.

I *sometimes* can get a triple-click to select a word, but it's inconsistent. I also believe it's caused by the introduction of the new search engine menu. It seems that the menu pop up eats the first click, so the usual text-selection actions aren't behaving normally.

Comment 4

3 years ago
Can reproduce with Firefox 36.0.4 with my profile (maybe the speed is different from a new profile, but I am not sure which way).
Component: Untriaged → Search
OS: Mac OS X → All

Updated

3 years ago
See Also: → bug 1128345

Comment 5

3 years ago
Does this bug still reproduce in Firefox 37? Double click works OK and as expected for me in Firefox 37. In fact, the entire search bar works just fine in Firefox 37. Please upgrade to Firefox 37 and tell us if you are still having problems.
(Reporter)

Comment 6

3 years ago
It seems fixed in v37.0.1

Comment 7

3 years ago
Yes, search bar double click interaction appears to be back to normal in Firefox 37.0.1 for me.

Comment 8

3 years ago
Per above comments.  Thanks.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.