Switch Bluetooth to Bluedroid until FOTA update is ready

RESOLVED FIXED in Firefox 38, Firefox OS v2.2

Status

Firefox OS
Bluetooth
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: tzimmermann, Assigned: tzimmermann)

Tracking

unspecified
2.2 S6 (20feb)
All
Gonk (Firefox OS)

Firefox Tracking Flags

(firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

In bug 1130288, there's a discussion about how to update daemons using (F)OTA updates. This seems impossible right now and dogfooders are left without Bluetooth.

We should switch Bluetooth back to the old backend, so Bluetooth is available again until the problem is solved.
Created attachment 8563308 [details] [diff] [review]
[01] Bug 1132388: Use Bludroid until update problem has been solved

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

  https://bugzilla.mozilla.org/show_bug.cgi?id=1005934

User impact if declined: 

  No Bluetooth for dogfooders because of inability to update system daemons

Testing completed: 

  Locally

Risk to taking this patch (and alternatives if risky): 

  Small. No major code changes. The patch only changes a default value.

String or UUID changes made by this patch:

  None
Attachment #8563308 - Flags: review?(shuang)
Attachment #8563308 - Flags: approval-mozilla-b2g37?
Attachment #8563308 - Flags: review?(shuang) → review+
https://hg.mozilla.org/mozilla-central/rev/e0092755a03f
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)

Updated

3 years ago
Attachment #8563308 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6b5a8f183c55
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
status-firefox36: --- → wontfix
status-firefox37: --- → wontfix
You need to log in before you can comment on or make changes to this bug.