Focusing rocketbar loses focus immediately; errors from Keyboard app too

RESOLVED DUPLICATE of bug 1134493

Status

RESOLVED DUPLICATE of bug 1134493
4 years ago
4 years ago

People

(Reporter: mikehenrty, Unassigned)

Tracking

({dogfood, regression})

unspecified
ARM
Gonk (Firefox OS)
dogfood, regression

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

Attachments

(1 attachment)

The errors are below:

"InputMethodManager: inputcontext.getText() was rejected." "
    at InputMethodManager.prototype.updateInputContextData/p< (app://keyboard.gaiamobile.org/js/keyboard/input_method_manager.js:412:4)" input_method_manager.js:412:4


"InputMethodGlue: call setUpperCase() when inputContext does not exist." "
    at InputMethodGlue.prototype.setUpperCase (app://keyboard.gaiamobile.org/js/keyboard/input_method_manager.js:250:4)" input_method_manager.js:250:4
TypeError: this.app.inputContext is null
Stack trace:
InputMethodManager.prototype.switchCurrentIMEngine/p<@app://keyboard.gaiamobile.org/js/keyboard/input_method_manager.js:490:7
 "
    at AbortablePromiseQueue.prototype.run/this._queuedTasks< (app://keyboard.gaiamobile.org/js/keyboard/abortable_promise_queue.js:75:27)"
John, do you know anything about this?
Flags: needinfo?(jlu)
I tend to think you're experiencing something related to bug 1129344 but 1) your bug description is a bit different (merely focusing the rocketbar causes it to lose focus, without any interaction on the keyboard?) and 2) I can't reproduce this bug here.

And a bit more information:

The keyboard app shows such error when it loses its input context (e.g. the input field focus is blurred) while bootstraping to associate itself to a input field.

Thus the error is actually the effect of the blurring instead of the cause of blurring.
Flags: needinfo?(jlu)
Oh wait, I think I've just reproduced the bug: it's only there the first time you focus rocket after reboot, and you have to enter rocketbar from anything other than System app.

A good STR would be:
1. Reboot.
2. Go to Settings.
3. Click on the rocket bar to focus it.

and
4. Rocket bar is focused but the focus will blur very shortly afterwards, and no keyboard is brought up.

Still my previous opinion stands and I can't think of any recent changes on Input Management or Keyboard app that can introduce this. Shall we just ask for qawanted?
Flags: needinfo?(mhenretty)
Created attachment 8564076 [details]
[screenshot] no keyboard

Yeah, let's get a regression-window based on the STR in comment 3.

Just for clarification to QA, when this bug reproduces it looks like the screenshot. In other words, the screen will darken but we will get no keyboard.

Also, can we check if this reproduces on 2.2?
Flags: needinfo?(mhenretty)
Keywords: regressionwindow-wanted
QA Contact: bzumwalt
Regression Window:

Last working B2G-Inbound build:
Device: Flame 3.0
Build ID: 20150129194440
Gaia: 0630174909e47e6c62a6a92e07cee1a901d97028
Gecko: e539715710f6
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First broken B2G-Inbound build:
Device:  Flame 3.0
BuildID: 20150129205239
Gaia: 21829dd3fcf7b107bf16e798aa39a17c42d66fef
Gecko: a66f5d17e9cf
Version: 38.0a1 (3.0)
Firmware: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Working Gaia with Broken Gecko issue does NOT reproduce:
Gaia: 0630174909e47e6c62a6a92e07cee1a901d97028
Gecko: a66f5d17e9cf

Working Gecko with Broken Gaia issue DOES reproduce:
Gaia: 21829dd3fcf7b107bf16e798aa39a17c42d66fef
Gecko: e539715710f6


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/0630174909e47e6c62a6a92e07cee1a901d97028...21829dd3fcf7b107bf16e798aa39a17c42d66fef


Issue appears to occur due to changes in bug 1124816
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Alive, can you take a look at this please? This might be the result of the work done on bug 1124816
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alive)
Can we get a retest of this now that bug 1129344 landed? This might be a dupe.
Keywords: qawanted
From comment 3 I believe this is dupe of bug 1129344. But awaiting qa testing.
Assignee: nobody → alive
Flags: needinfo?(alive)
I am still seeing this occur in Flame 3.0 following STR from comment 3

After restarting phone, launching rocketbar from an app (i.e. Settings) shows cursor momentarily, but cursor disappears and keyboard never appears. Interestingly, launching rocketbar from homescreen after restarting has similar behavior, briefly bringing up keyboard which is dismissed moments later without user input. Both scenarios leave user on a empty, dimmed rocketbar screen.

Device: Flame 3.0 Master
Build ID: 20150216010344
Gaia: f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gecko: e0cb32a0b1aa
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Duplicate of this bug: 1133635
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: --- → 2.2?
FYI, I'm changing summary and component to avoid confusion.
Component: Gaia::System::Input Mgmt → Gaia::System::Window Mgmt
Summary: Focusing rocketbar throws errors, causes keyboard to lose focus → Focusing rocketbar loses focus immediately; errors from Keyboard app too
Regression
blocking-b2g: 2.2? → 2.2+
Keywords: regression
Keywords: dogfood
For what it's worth, this might be a gecko regression, and not actually caused by bug 1124816. The reason I say that, is I backed out bug 1124816 manually, flashed gaia, and was still seeing the issue. I then flashed an old gecko, and the issue went away.
(In reply to Michael Henretty [:mhenretty] from comment #13)
> For what it's worth, this might be a gecko regression, and not actually
> caused by bug 1124816. The reason I say that, is I backed out bug 1124816
> manually, flashed gaia, and was still seeing the issue. I then flashed an
> old gecko, and the issue went away.

Good! de-assign myself.
Assignee: alive → nobody
Keywords: regressionwindow-wanted
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1134493
You need to log in before you can comment on or make changes to this bug.