Register/Sign in and other buttons are truncated on Firefox OS 1.1

VERIFIED FIXED in 2015-03-03

Status

Marketplace
Consumer Pages
P2
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: mat, Assigned: spasovski)

Tracking

2015-03-03
Points:
---

Details

Attachments

(8 attachments)

(Reporter)

Description

3 years ago
Created attachment 8563413 [details]
Screenshot showing the truncated buttons on 1.1

STR:
- Load Marketplace on Firefox OS 1.1
- Tap the gear icon

Expected:
- Buttons look normal

Actual:
- Notice every button - Register, Sign In, but also Get Involved, Privacy Policy and Terms of Use are truncated and does not take the full width - only a few characters are shown, then an ellipsis. For Sign In/Register, you can't even see more than 2 characters.

Happens on dev and prod, in the app and in the browser. Does not happen on FxOS 1.3 and 2.x.
Looks like it's the display: -moz-box on .account-settings-save from the display-flex() mixin. Remove that and it looks fine.

iirc legacy flexbox won't do anything with a percentage width.

Updated

3 years ago
Duplicate of this bug: 1132731

Updated

3 years ago
Blocks: 1103195

Updated

3 years ago
Priority: -- → P2
(Assignee)

Updated

3 years ago
Assignee: nobody → dspasovski
(Assignee)

Comment 3

3 years ago
https://github.com/mozilla/fireplace/pull/1046
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Target Milestone: --- → 2015-03-03

Comment 4

3 years ago
Buttons look OK on Inari 1.1 Spanish.

Comment 5

3 years ago
Created attachment 8570782 [details]
1_ButtonsLooksOK.png

Comment 6

3 years ago
Created attachment 8570786 [details]
2_ButtonsLooksOK.png

Comment 7

3 years ago
Created attachment 8570787 [details]
3_ButtonsLooksOK.png

Comment 8

3 years ago
Created attachment 8570788 [details]
4_ButtonsLooksOK.png

Comment 9

3 years ago
Created attachment 8570790 [details]
5_ButtonsLooksOK.png

Comment 10

3 years ago
Created attachment 8570791 [details]
6_ButtonsLooksOK.png

Comment 11

3 years ago
Created attachment 8570792 [details]
7_ButtonsLooksOK.png

Comment 12

3 years ago
Verified as fixed for Inari 1.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.