Feed Reader sends wrong Accept header

RESOLVED FIXED in Thunderbird 41.0

Status

MailNews Core
Feed Reader
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: wiktor, Assigned: alta88)

Tracking

Thunderbird 41.0
x86_64
All

Thunderbird Tracking Flags

(thunderbird39 affected, thunderbird40 fixed, thunderbird41 fixed, thunderbird_esr3839+ fixed, seamonkey2.35+ fixed, seamonkey2.36 affected, seamonkey2.37 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.111 Safari/537.36

Steps to reproduce:

1. Subscribed to my feed through built-in Thunderbird's Feed Reader.


Actual results:

I saw the Accept header in my server logs has value "text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8"

This breaks for example Content Negotiation.


Expected results:

The Accept header should be something similar to "application/atom+xml,application/rdf+xml,application/rss+xml,application/x-netcdf,application/xml;q=0.9,text/xml;q=0.2,*/*;q=0.1" as the expected file type is an XML feed.
Component: Untriaged → Feed Reader
Product: Thunderbird → MailNews Core

Updated

3 years ago
Duplicate of this bug: 1138202

Comment 2

3 years ago
Bug 1138202 was on a Mac OS X, so setting it to All OSes. Macs are using x86_64 bits CPUs so I keep it as it is.
OS: Windows 8.1 → All
(Assignee)

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

2 years ago
Created attachment 8625501 [details] [diff] [review]
feedAccept.patch
Assignee: nobody → alta88
Attachment #8625501 - Flags: review?(mkmelin+mozilla)

Comment 4

2 years ago
Comment on attachment 8625501 [details] [diff] [review]
feedAccept.patch

Review of attachment 8625501 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #8625501 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 5

2 years ago
https://hg.mozilla.org/comm-central/rev/3092759d5f48

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 41.0

Comment 6

2 years ago
Should this be considered for uplift to Thunderbird 38?

Updated

2 years ago
tracking-seamonkey2.35: --- → ?
(Assignee)

Comment 7

2 years ago
sure, why not.  it likely has a very low incidence of being an issue and the change is also very low risk.

Updated

2 years ago
Attachment #8625501 - Flags: approval-comm-esr38+
Attachment #8625501 - Flags: approval-comm-beta+
Attachment #8625501 - Flags: approval-comm-aurora+

Comment 8

2 years ago
http://hg.mozilla.org/releases/comm-beta/rev/4bb56ff83ba7
http://hg.mozilla.org/releases/comm-esr38/rev/04a14456d206

No push to aurora since uplift occurred.
status-seamonkey2.35: --- → affected
status-seamonkey2.36: --- → affected
status-seamonkey2.37: --- → fixed
status-thunderbird39: --- → affected
status-thunderbird40: --- → fixed
status-thunderbird41: --- → fixed
status-thunderbird_esr38: --- → fixed
tracking-thunderbird_esr38: --- → 39+

Updated

2 years ago
Blocks: 1177041

Comment 9

2 years ago
http://hg.mozilla.org/releases/comm-release/rev/da4fcbb68d85 SEAMONKEY_2_35_RELEASE_BRANCH
status-seamonkey2.35: affected → fixed
tracking-seamonkey2.35: ? → +
You need to log in before you can comment on or make changes to this bug.