Add support for emulating "-webkit" prefixed animation CSS, via CSS Unprefixing Service

RESOLVED DUPLICATE of bug 1179408

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1179408
3 years ago
2 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
As noted in bug 1107378 comment 19, there's at least one site (hao123) that will likely be on our prefixing "fixlist" that uses prefixed CSS animation syntax. 

Sample CSS, provided by Karl Dubost:

@-webkit-keyframes myrotate{}
-webkit-animation-name:myrotate;
-webkit-animation-duration:.8s;
-webkit-animation-fill-mode:both;
-webkit-animation-timing-function:ease-in

Source: http://s0.m.hao123img.com/static/html5-index/css/index_2c2ec19.css

(karl notes that Yahoo! Japan also uses prefixed CSS animations, and they may end up on our fixlist as well.)

Hence, filing this bug on emulating support for the -webkit prefixed animation properties and the @-webkit-keyframes rule, via the CSS Unprefixing service (only for sites on our fixlist of course).
(Reporter)

Updated

3 years ago
Assignee: nobody → dholbert
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Updated

2 years ago
See Also: → bug 1179408
(Reporter)

Comment 1

2 years ago
Unassigning, as I'm not actively working on this at the moment.

(Also, if these properties take the same syntax/keywords as our supported versions, we may just want to support them natively as aliases, instead of relying on the js-implemented CSS Unprefixing Service. That will probably happen via bug 1179408.)
Assignee: dholbert → nobody
Status: ASSIGNED → NEW
(Reporter)

Comment 2

2 years ago
Duping forward to bug 1179408.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1179408
You need to log in before you can comment on or make changes to this bug.