Expose logical inline property names from spec instead of prefixed ones (unprefix -moz-margin-start, -moz-margin-end, -moz-padding-start, -moz-padding-end)

RESOLVED DUPLICATE of bug 1118103

Status

()

RESOLVED DUPLICATE of bug 1118103
4 years ago
4 years ago

People

(Reporter: sebo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Logical CSS inline properties for margin, padding and border are currently exposed via their previous -moz-*-{start,end} equivalents.

Instead the logical properties should be exposed using the spec[1] names.

In the test case within the URL field I'd expect this as output:

div { margin-inline-start: 10px; padding-inline-start: 10px; border-inline-start: 10px solid blue;}

Sebastian

[1] http://dev.w3.org/csswg/css-logical-props/#logical-page
(Reporter)

Updated

4 years ago
Blocks: 1083134
Does our implementation actually match the spec?
Summary: Expose logical inline property names from spec instead of prefixed ones → Expose logical inline property names from spec instead of prefixed ones (unprefix -moz-margin-start, -moz-margin-end, -moz-padding-start, -moz-padding-end)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118103
(In reply to Boris Zbarsky [:bz] from comment #1)
> Does our implementation actually match the spec?

Yes.
And by "yes" I mean "no, except for the rule to resolve against parent element's writing mode for some properties, which fantasai agreed to remove from the spec".
(In reply to Cameron McCormack (:heycam) from comment #4)
> "no, except for the rule to resolve against parent
> element's writing mode for some properties, which fantasai agreed to remove
> from the spec".

"yes, except for ..."
You need to log in before you can comment on or make changes to this bug.