[Accessibility] Fix visibility issues in video app.

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Video
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: yzen, Assigned: yzen)

Tracking

unspecified
2.2 S6 (20feb)
x86
Mac OS X

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
When an overlay dialog is displayed, it should be elusively visible and rest of the content has to be explicitly hidden, otherwise the screen reader user will be able to get to navigate to it.
(Assignee)

Comment 1

3 years ago
Also screen reader can access #picker-header when not performing a pick activity. That would need to be fixed.
Summary: [Accessibility] Fix visibility issues around overlays in video app. → [Accessibility] Fix visibility issues in video app.
Created attachment 8564275 [details] [review]
[gaia] yzen:bug-1132929 > mozilla-b2g:master
(Assignee)

Comment 3

3 years ago
Created attachment 8564276 [details] [review]
Github pull request.
Attachment #8564276 - Flags: review?(rnicoletti)
(Assignee)

Updated

3 years ago
Attachment #8564276 - Attachment is obsolete: true
Attachment #8564276 - Flags: review?(rnicoletti)
(Assignee)

Updated

3 years ago
Attachment #8564275 - Flags: review?(rnicoletti)
(Assignee)

Updated

3 years ago
Whiteboard: [b2ga11y p=1]
Comment on attachment 8564275 [details] [review]
[gaia] yzen:bug-1132929 > mozilla-b2g:master

The changes look good. I added one nit in the PR comments.
Attachment #8564275 - Flags: review?(rnicoletti) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

3 years ago
Comment on attachment 8564275 [details] [review]
[gaia] yzen:bug-1132929 > mozilla-b2g:master

[Approval Request Comment] This PR fixes issues with visibility around the Video app for screen reader users
[Bug caused by] (feature/regressing bug #): improvement, not a bug
[User impact] if declined: If declined the screen reader user will be able to access views that are not visible to users otherwise.
[Testing completed]: on device
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8564275 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8564275 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/3d5bc54ec9c208a23f48741000251974148c6df3
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S6 (20feb)
You need to log in before you can comment on or make changes to this bug.