Change the marketplace-langpacks activity to marketplace-category

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: stas, Assigned: stas)

Tracking

unspecified
2.2 S6 (20feb)

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
As per bug 1122272 comment 1, the web activity that was eventually implemented in the Marketplace has the following signature:

new window.MozActivity({
    name: 'marketplace-category',
    data: {
        slug: 'langpacks',
        fxos_version: '2.2'
    }
});

I'll have a pull request in a few to update the Settings app code.

Comment 1

3 years ago
Created attachment 8564251 [details] [review]
[gaia] stasm:1132974-marketplace-langpacks > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8564251 [details] [review]
[gaia] stasm:1132974-marketplace-langpacks > mozilla-b2g:master

Arthur, there has been a change on the Marketplace side after bug 1115798 landed and the web activity that we need to launch from the 'Get More Languages' link in the Settings app needs a new signature.

Mat, just to make sure I got this right, can you take a look at verify that this is indeed what the Marketplace expects now?

Thanks!
Attachment #8564251 - Flags: review?(mpillard)
Attachment #8564251 - Flags: review?(arthur.chen)
Comment on attachment 8564251 [details] [review]
[gaia] stasm:1132974-marketplace-langpacks > mozilla-b2g:master

r=me, thanks.
Attachment #8564251 - Flags: review?(arthur.chen) → review+

Updated

3 years ago
See Also: → bug 1122272
Comment on attachment 8564251 [details] [review]
[gaia] stasm:1132974-marketplace-langpacks > mozilla-b2g:master

Looks ok to me.
Attachment #8564251 - Flags: review?(mpillard) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Comment 5

3 years ago
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/baa8bc226b87b48e45f7a2140fceea860cc3aec4

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

3 years ago
Comment on attachment 8564251 [details] [review]
[gaia] stasm:1132974-marketplace-langpacks > mozilla-b2g:master

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #):  Bug 1122272

[User impact] if declined:  Users won't be able to open the Marketplace listing with langpacks

[Testing completed]: on the device

[Risk to taking this patch] (and alternatives if risky): very low; it's only changing the name of the web activity invoked from the Settings app

[String changes made]:  none
Attachment #8564251 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8564251 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/ef00758be4cfa6906634a9fa7137eb584119b51a
Assignee: nobody → stas
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S6 (20feb)
This bug has been verified as "pass" on the latest nightly build of Flame v2.2&Master.


STR:
1.Go to Settings-> tap "Language"-> tap "Get More languages".
2.Select "Marketplace".

Actual results: After the 'Get More Languages' link is visible in Settings app, user is able to open the Marketplace listing with langpacks.
See attachment: verified_Flame_v2.2.3gp
Reproduce rate: 0/10


Device: Flame v2.2 (Verified, v18D_v4)
Build ID               20150723002503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d8326043baec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150723.041700
Firmware Date          Thu Jul 23 04:17:12 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (Verified, v18D_v4)
Build ID               20150723160204
Gaia Revision          ec2199b324304d3678b6a98a08a31bdc13c9e984
Gaia Date              2015-07-23 17:16:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cb8bdb8ffaef
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150723.193607
Firmware Date          Thu Jul 23 19:36:19 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Created attachment 8638491 [details]
verified_Flame_v2.2.3gp
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.