Closed Bug 1133008 Opened 7 years ago Closed 7 years ago

[Window Management] Zooming/Fading app transition has graphical tiling.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED DUPLICATE of bug 1133961
blocking-b2g 2.5?
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: Marty, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Description:
If the user activates a zooming/fading app transition, they will see graphical corruption in the left and bottom portions of the screen.  This corruption  looks like re-draw tiling of the page the user is leaving, though sometimes looks like rainbow colored static/snow.

Note: This issue occurs in the 'fade out' transition, but does not seem to occur in the 'fade in' transition when dismissing the resultant screens.

This issue has been seen in zooming app transitions found in the following places:
-Launching a Smart Collection from the Homescreen
-Adding a web page to the Homescreen
-Adding a Smart Collection to the Homescreen
-Adding a Contact to an SMS in the Messages app.
-Tapping a screenshot notification and opening the gallery preview

Repro Steps:
1) Update a Flame to 20150213010213
2) From the Homescreen, launch one of the default Smart Collections (Social, Games, or Music)

Actual:
Tiling or Static graphical corruption is present during the app transition


Expected:
App transition looks smooth without graphical issues.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150213010213
Gaia: 2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gecko: 2f5c5ec1a24b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 7/7
See attached: video clip (URL), logcat

------------------------------------------

This issue does NOT occur on Flame 2.2.
App transition looks smooth without graphical issues.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150213002503
Gaia: ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gecko: d04b78eeb536
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Graphical regression of a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
Gaia-Rev        d5a71cedb37dd45f439f672489db3994b349ac43
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/3094601af679
Build-ID        20150211221340
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150214.043959
FW-Date         Sat Feb 14 04:40:10 EST 2015
Bootloader      L1TC000118D0

First Broken Environmental Variables:
Device: Flame
Gaia-Rev        2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/81f979b17fbd
Build-ID        20150212064620
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150214.043959
FW-Date         Sat Feb 14 04:40:10 EST 2015
Bootloader      L1TC000118D0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: https://hg.mozilla.org/mozilla-central/rev/81f979b17fbd

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gecko: https://hg.mozilla.org/mozilla-central/rev/3094601af679
QA Whiteboard: [MGSEI-Triage+]
Piwei, can you take a look at this please? I need to know the commit that caused this so I can assign it to the right person.
Flags: needinfo?(pcheng)
The window at comment 2 is NOT from mozilla inbound and should be bisected further.

The real mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150211190942
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 6ed69c4d2c15
Version: 38.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150211230942
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 07479758ab68
Version: 38.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6ed69c4d2c15&tochange=07479758ab68

Caused by changes made in Bug 1127066.
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
Flags: needinfo?(pcheng) → needinfo?(ktucker)
Botond,can you take a look at this please? Here is another issue that seems to be the result of the work done on Bug 1127066.
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+][QAnalyst-Triage+]
Depends on: 1127066
Flags: needinfo?(ktucker)
Blocks: 1127066
No longer depends on: 1127066
Flags: needinfo?(botond)
Dupe of bug 1133961. This should be fixed shortly once bug 1134762 lands.
Blocks: 1134202
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(botond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1133961
You need to log in before you can comment on or make changes to this bug.