[Windows Management] [SIM PIN] - SIM PIN screen does not take up the full-screen, allowing interaction and partial viewing of apps opened by lockscreen notifications.

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: apastor)

Tracking

({regression})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], [systemsfe], )

Attachments

(3 attachments)

Reporter

Description

4 years ago
Description:
On the Lockscreen you can interact with notifications to open a relevant app depending on the notification type. If you have a SIM PIN enabled, clicking 'open' on any of these notifications will transition to the SIM PIN screen but then you will see in the header / notification bar section the phone continue to transition to the relevant app. This is particularly distracting and poor looking (shown in video) when the notification was a screenshot (due to screenshot header showing above SIM PIN screen).

Notes: This seems to be due to the SIM PIN notification bar header now being transparent as opposed to a solid color in 2.2
Users can also interact with the non-visisble search box in the notification bar while on the SIM PIN screen but that seems like a separate issue or a non-issue. 


Repro Steps: Phone must have SIM
1) Update a Flame to 20150213010213
2) Take a screenshot 
3) Activate SIM PIN
4) Long press power button and select Restart
5) From Lockscreen select screenshot notification and select Open

Actual:
SIM PIN page has transparent header (notification bar), can see transition to screenshot behind it, looks poor

Expected:
User will not see apps opening behind SIM PIN page, notification bar will not be transparent. 

Environmental Variables:
Device: Flame 3.0
Build ID: 20150213010213
Gaia: 2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gecko: 2f5c5ec1a24b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5:
See attached: Video: http://youtu.be/l6DF2tgfxt4
--------------------------------------------------------------------------------

This issue does NOT reproduce in 2.2

Actual Results: The notification bar is a solid color and you do not see changes taking place behind it / apps open behind it.
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Graphical regression that has functional impact of a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
mozilla-inbound regression window:

Last Working Environmental Variables:
Gaia-Rev        8238eeacc7030b2cdbf7ab4eba2f36779b702599
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/29b05d283b00
Build-ID        20150129152731
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150120.192939
FW-Date         Tue Jan 20 19:29:50 EST 2015
Bootloader      L1TC000118D0

First Broken Environmental Variables:
Gaia-Rev        45475198737a504d81932a9c90002902054fce23
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/cdd62a8caf30
Build-ID        20150130090036
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150120.192939
FW-Date         Tue Jan 20 19:29:50 EST 2015
Bootloader      L1TC000118D0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 8238eeacc7030b2cdbf7ab4eba2f36779b702599
Gecko: cdd62a8caf30

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 45475198737a504d81932a9c90002902054fce23
Gecko: 29b05d283b00
QA Whiteboard: [MGSEI-Triage+]
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing], [systemsfe]
Can we get a regression window analysis?
Keywords: qawanted
QA Contact: pcheng
The window on comment 2 was done in Central, and here's the pushlog:

https://github.com/mozilla-b2g/gaia/compare/8238eeacc7030b2cdbf7ab4eba2f36779b702599...45475198737a504d81932a9c90002902054fce23

Please tag window-wanted again if further bisection is needed from inbound.

---

Note that on latest 3.0 this issue is now showing differently - instead of showing header portion from background, it is now showing the bottom portion from background. See attached screenshot.
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 3.0? → 3.0+
Hm the screenshot shows a different behavior than the video.
Alberto, can you take a look?
Flags: needinfo?(apastor)
Assignee

Updated

4 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Assignee

Updated

4 years ago
Attachment #8597311 - Flags: review?(alive)
Comment on attachment 8597311 [details] [review]
[gaia] albertopq:1133029-sim-fullscreen > mozilla-b2g:master

The only thing I wonder is if we should just change statusbar height here:
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/statusbar.js#L71
to reflect the top most window's fullscreen state.
The patch itself is fine, but I will appreciate if you could try fixing statusbar without changing system dialog.
Attachment #8597311 - Flags: review?(alive) → review+
Assignee

Comment 8

4 years ago
That makes sense. I'll change it. Thanks!
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S11 (1may)
This issue is verified fixed on the latest Nightly Flame 3.0 build

Actual Results: The SIM Pin screen covers the whole screen.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150506010204
Gaia: 3e6fd1e0a478af2c95d09ce95c2c6de2de2fec14
Gecko: ba44099cbd07
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Assignee

Updated

4 years ago
Duplicate of this bug: 1167130
Assignee

Comment 12

4 years ago
It seems that 2.2 is affected. Should we uplift?
blocking-b2g: 3.0+ → 2.2?
blocking-b2g: 2.2? → 2.2+
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(apastor)
Assignee

Comment 14

4 years ago
Comment on attachment 8597311 [details] [review]
[gaia] albertopq:1133029-sim-fullscreen > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: When opening a lockscreen notification, the SIM pin dialog is not shown fullscreen
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky): Simple change with tests. Low risk
[String changes made]: -
Flags: needinfo?(apastor)
Attachment #8597311 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8597311 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Updated

4 years ago
Keywords: verifyme
This bug has been verified as pass on latest Nightly build of Flame v2.2 and Nexus 5 v2.2 by the STR in Comment 0.

Actual results: User will not see the screenshot page opening behind SIM PIN page, notification bar will not be transparent. 
See attachment: verified_v2.2.mp4
Reproduce rate: 0/8


Device: Flame v2.2 build(Pass)
Build ID               20150531162502
Gaia Revision          b4582cc394e0919623263997c0cdb0b4751a1403
Gaia Date              2015-05-31 11:06:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/78d8b0a4303d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150531.195816
Firmware Date          Sun May 31 19:58:28 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v2.2 build(Pass)
Build ID               20150531002502
Gaia Revision          0a46394dbee0ed2eb71a136cee38ddd8549dd597
Gaia Date              2015-05-30 14:50:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ed2f6aeb1d81
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150531.043812
Firmware Date          Sun May 31 04:38:27 EDT 2015
Bootloader             HHZ12f
You need to log in before you can comment on or make changes to this bug.