Flame: Pressing forward on lockscreen UI will make the music play UI disappear

RESOLVED INVALID

Status

Firefox OS
Gaia::Music
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: njpark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR:
Load a few music in the phone
Open Music App, play the music
Pause, then press power button to lock the phone
Press power button again, music play UI will appear
Press Play, then continue press forward button
Actual:
When it reaches the end of the playlist (or in case Music app was playing a single song, after two taps) the UI disappears
Expected:
UI should not disappear

Version Info:
Gaia-Rev        2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2f5c5ec1a24b
Build-ID        20150213010213
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150213.043439
FW-Date         Fri Feb 13 04:34:49 EST 2015
Bootloader      L1TC000118D0
	
This also reproduces in 2.2
Build-ID        20150209002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150209.040038
FW-Date         Mon Feb  9 04:00:51 EST 2015
Bootloader      L1TC000118D0

Comment 1

3 years ago
That's intentional. If the playlist ends, the music player is stopped (as opposed to being merely paused). If it's stopped, the now playing widget is closed because you wouldn't be able to do anything with it anyway, as there's no longer a playlist.
(Reporter)

Comment 2

3 years ago
Per comment 1, closing this bug
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.