Wordpress display is not loading CSS since February 13th nightly build

RESOLVED DUPLICATE of bug 1133156

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 1133156
3 years ago
3 years ago

People

(Reporter: Frederic Bezies, Assigned: bagder)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
I noticed that CSS is no longer loaded on my wordpress site. It started with february 13th nightly which is build from https://hg.mozilla.org/mozilla-central/rev/2f5c5ec1a24b

I browsed tinderbox builds, and I noticed that the first broken build is : https://hg.mozilla.org/mozilla-central/rev/81f979b17fbd

Looking at the very long changeset (more than 50 bugs listed), I can't say which one is guilty here. Can you help me here ?

Thanks a lot !
(Reporter)

Comment 1

3 years ago
Of course, I used a clean profile to track the guilty changeset.
(Reporter)

Comment 2

3 years ago
Forgot to add : it happens with both e10s activated or not.
Do you have a link to the site?

One interesting thing in that push (<http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b5cfc9fad354&tochange=81f979b17fbd> for the record) is bug 237623 so if the server's response for the CSS is not a valid HTTP response in this case that could be causing the issue..
Flags: needinfo?(fredbezies)
(Reporter)

Comment 4

3 years ago
(In reply to Boris Zbarsky [:bz] from comment #3)
> Do you have a link to the site?
> 
> One interesting thing in that push
> (<http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=b5cfc9fad354&tochange=81f979b17fbd> for the record)
> is bug 237623 so if the server's response for the CSS is not a valid HTTP
> response in this case that could be causing the issue..

Well, I have no link to give you, as it is my admin wordpress page ! You can understand why I'll keep it private.

I'll try reverting this patch and tell you what's happening. Thanks for the tip !
Flags: needinfo?(fredbezies)
(Reporter)

Comment 5

3 years ago
Here is a two screenshot (with the url partially hidden) : both working and broken wordpress dashboard display.

Will try a build with patch for bug 237623 reverted asap and report.
(Reporter)

Comment 6

3 years ago
Created attachment 8564577 [details]
broken-wordpress-dashboard.png

Broken dashboard display (No CSS loaded)
(Reporter)

Comment 7

3 years ago
Created attachment 8564578 [details]
working-wordpress-dashboard.png

Working wordpres dashboard (using a february 12th homemade build)

Updated

3 years ago
Blocks: 1133239
Bug 1133239 could give some clues: "... could not load style sheet generated by PHP and than compressed using gzdeflate()".
(Reporter)

Comment 9

3 years ago
(In reply to Mats Palmgren (:mats) from comment #8)
> Bug 1133239 could give some clues: "... could not load style sheet generated
> by PHP and than compressed using gzdeflate()".

I didn't search for this. Reverting patch for bug 237623 fixes this bug. Thanks Boris for the hint.

Could this bug be a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1133156 in some ways ?

Comment 10

3 years ago
Created attachment 8564592 [details]
Piwik

It's not only the Wordpress administration, with Piwik another popular software is affected.
Depends on: 1133156
Component: CSS Parsing and Computation → Networking: HTTP
(Assignee)

Updated

3 years ago
Assignee: nobody → daniel
the problematic code has been backed out but not merged to m-c yet
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1133156
You need to log in before you can comment on or make changes to this bug.