Status

()

Core
Layout
P3
critical
VERIFIED DUPLICATE of bug 12232
19 years ago
a year ago

People

(Reporter: Shashi Narain, Assigned: joki (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
After the page loads, click the icon that contains the Mona Lisa. A "window"
appears containing links. If you move your mouse over the links, you will see
that they are working fine.

Now click the icon that contains the computer. Again a "window" opens containing
links. These links also work fine.

Here is where the strangeness happens...click the Mona Lisa icon again. If you
move your mouse over the links you will see that they are no longer working. And
to add to the mystery, if you move your mouse inside the "window" you will see
the ghost links from the last "window" opened even though the "window" is not
there.

It doesn't really matter what combination of "windows" you open/close, the
results are the same.

The only cure for now is to reload the page.

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
The problem seems tp be that when 'visibility' is changed to 'hidden' we aren't
hiding the view and that's why the events are getting through.

This is the same problem described in 10402

*** This bug has been marked as a duplicate of 10402 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
verified dup
(Reporter)

Comment 3

18 years ago
This is bug has been marked as a dup of #10402, which in turn has been marked as 
a dup of #2553, which in turn has been marked as verified and fixed (I hope I 
have not confused all of you :-) Sadly, the problem still exists so I am 
re-opening this specific bug.

Here are my comments on what I am experiencing on Win98 using the latest M13 
build...after the page has loaded and the DHTML completed, move your mouse 
inside the "Welcome Window". You will see links from a hidden layer bleed 
through to layers that are visible.

Here is an even more serious problem...click the Mona Lisa icon. The "Welcome 
Window" will close and the "Turning On The Style Window" will open. Move your 
mouse along the first row of links (Football World, Team Mozilla, etc.) and you 
will see that the links from the hidden layer have "over-rided" the links from a 
visible layer. Now move your mouse to the second row of links (HIP Jeans, 
Safety, etc,) and you will see that the links completely don't work.

All the layers on the page experience the same problem...*except for one*. Click 
the icon which has the computer on it (the relevent layer will open up). If you 
move your mouse around this layer, all the links are correct. As it turns out, 
this is the offending layer that is bleeding it's links through to visible 
layers. But there is one key difference between this layer and all the others. 
This layer contains links anchored to GIF files and thus maybe causing the 
problem.

What I am going to do is look into the HTML code and write up a testcase to see 
if it is really the GIF's causing the bug. I will also give this bug a test run 
on Linux to see if it is occuring on that end.
Status: VERIFIED → REOPENED
(Reporter)

Updated

18 years ago
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

18 years ago
I did some "experimenting" with the HTML code and this is what I experienced...

The first thing I did was change the links so that it was *not* anchored to a 
GIF file but instead to normal text. This did absolutely nothing as the links 
were still bleeding through and over-riding the visible links.

The next thing I did was to completely comment out the last layer coded in the 
HTML to see whether something was inherently wrong with this last layer. And 
this is where I found something strange...the bleed through and over-riding of 
links was still occurring but now it involved the new, last layer. To put it 
simply, whichever layer is coded *last* in the HTML bleeds it's links to all 
other layers and renders all visible links dead.

Since the page has alot of stuff going on, I will try to simplify this bug so 
that a testcase can be created.

Comment 5

18 years ago
Okay, the problem of 'hidden' elements getting events anyway is a known event 
handling issue. Re-assigning to Tom
Assignee: troy → joki
Status: REOPENED → NEW
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 6

18 years ago
Adding micro testcase:
http://www.taboca.com/jan00nscp/dom/demos/dom2/on/indexhid.html
Note: left-top corner of the window have a mozilla.org a href link with 
visibility:hidden.

*** This bug has been marked as a duplicate of 12232 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
VERIFY dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.