langpack-install-success tells user to go 'Settings > Languages', should be 'Settings > Language'

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: aryx, Assigned: aryx)

Tracking

({late-l10n})

unspecified
2.2 S7 (6mar)
x86_64
Windows 8.1
late-l10n

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

langpack-install-success
is
{{ appName }} installed. Go to Settings > Languages to enable it.
but should be
{{ appName }} installed. Go to Settings > Language to enable it.
Created attachment 8564756 [details] [review]
[gaia] Archaeopteryx:settings-language > mozilla-b2g:master
Attachment #8564756 - Flags: review?(gandalf)
Comment on attachment 8564756 [details] [review]
[gaia] Archaeopteryx:settings-language > mozilla-b2g:master

Since Stas wrote this code, he should review the patch
Attachment #8564756 - Flags: review?(gandalf) → review?(stas)
Comment on attachment 8564756 [details] [review]
[gaia] Archaeopteryx:settings-language > mozilla-b2g:master

r=me, sorry for this typo.  Should we try to get this in on 2.2?
Attachment #8564756 - Flags: review?(stas) → review+
It's only a small issue, but it's tempting to also translate it wrong (= in plural).
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Comment on attachment 8564756 [details] [review]
[gaia] Archaeopteryx:settings-language > mozilla-b2g:master

Arthur, would you be willing to take a look at this tiny patch?
Attachment #8564756 - Flags: review?(arthur.chen)
Comment on attachment 8564756 [details] [review]
[gaia] Archaeopteryx:settings-language > mozilla-b2g:master

Looks like Arthur is out of the office this week.  EJ, would you mind taking a look at this, please?
Attachment #8564756 - Flags: review?(arthur.chen) → review?(ejchen)
It's Chinese New Year tomorrow (already today in Taipeh), so your chances to get reviews this or next week are slim.
Comment on attachment 8564756 [details] [review]
[gaia] Archaeopteryx:settings-language > mozilla-b2g:master

Looks good to me but the change was made in system app. Flagging the system owner instead.
Attachment #8564756 - Flags: review?(ejchen) → review?(alive)
Comment on attachment 8564756 [details] [review]
[gaia] Archaeopteryx:settings-language > mozilla-b2g:master

simple one!
Attachment #8564756 - Flags: review?(alive) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed
Comment on attachment 8564756 [details] [review]
[gaia] Archaeopteryx:settings-language > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1119758
[User impact] if declined: Label mentioned for changing the language after installing a language pack uses plural instead of singular like the real label
[Testing completed]: No testing (Marketplace hasn't language packs for master and I don't expect any for dev builds)
[Risk to taking this patch] (and alternatives if risky): Minimal (string and string ID change)
[String changes made]: Yes, one string
Attachment #8564756 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Keywords: late-l10n
Comment on attachment 8564756 [details] [review]
[gaia] Archaeopteryx:settings-language > mozilla-b2g:master

Although not a blocker, keeping in mind langpacks just landed in 2.2, approving this low risk improvement
Attachment #8564756 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/3e7ee2e5f3d0495ab333a2533cc5174434679bc7
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S7 (6mar)
You need to log in before you can comment on or make changes to this bug.