Closed Bug 1133360 Opened 7 years ago Closed 7 years ago

[Private Browser] Update identification overlay

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S6 (20feb)
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: mikehenrty, Assigned: mikehenrty)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

According to spec, we should have a darker edge gesture identification overlay.

https://mozilla.app.box.com/s/fanxlaw7ilhm0walsod6hy4ps47v9eh3
Comment on attachment 8564777 [details] [review]
[gaia] mikehenrty:bug-1133360-private-splash > mozilla-b2g:master

Only requesting feedback for now since we are still waiting on the final assets. But let's start the review process in the meantime.
Attachment #8564777 - Flags: feedback?(kgrandon)
Assignee: nobody → mhenretty
Comment on attachment 8564777 [details] [review]
[gaia] mikehenrty:bug-1133360-private-splash > mozilla-b2g:master

Still need the assets here, but this is looking good. I'm a fan of the approach. Thanks!
Attachment #8564777 - Flags: feedback?(kgrandon) → feedback+
Comment on attachment 8564777 [details] [review]
[gaia] mikehenrty:bug-1133360-private-splash > mozilla-b2g:master

Ok, assets uploaded, css adjusted.
Attachment #8564777 - Flags: review?(kgrandon)
Eric, this bug handles the overlay that appears over the private browser windows during edge gestures. The spec didn't mention icon size, so I kept them the same size as other icons (like browser) in this scenario. It looks different from the spec, but it seems weird to me to have an icon size that's bigger than all the other icons during edge gestures. What do you think?
Attachment #8565013 - Flags: ui-review?(epang)
Comment on attachment 8564777 [details] [review]
[gaia] mikehenrty:bug-1133360-private-splash > mozilla-b2g:master

The patch is looking good, but I have a few comments on github I'd like to have answered before leaving the R+. Please address and re-flag me for review. Thanks!
Flags: needinfo?(mhenretty)
Attachment #8564777 - Flags: review?(kgrandon)
Comment on attachment 8564777 [details] [review]
[gaia] mikehenrty:bug-1133360-private-splash > mozilla-b2g:master

Ah nice catch about the test. I also update the code based on your suggestion.
Flags: needinfo?(mhenretty)
Attachment #8564777 - Flags: review?(kgrandon)
Comment on attachment 8564777 [details] [review]
[gaia] mikehenrty:bug-1133360-private-splash > mozilla-b2g:master

I left a nit on github, but this looks good. Thank you!
Attachment #8564777 - Flags: review?(kgrandon) → review+
Comment on attachment 8565013 [details]
[screenshot] private overlay

That was fast :). Makes sense to me. R+
Thanks!
Attachment #8565013 - Flags: ui-review?(epang) → ui-review+
In master: https://github.com/mozilla-b2g/gaia/commit/137948ea0e036305b007b40d26aa57de4b1737e8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8564777 [details] [review]
[gaia] mikehenrty:bug-1133360-private-splash > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): new feature.

[User impact] if declined:
Missing feature for private browsing spec.

[Testing completed]:
Manually tested, and added unit test.

[Risk to taking this patch] (and alternatives if risky):
Simple change to the way we fetch icons for the edge gesture overlay. Small risk.

[String changes made]: none.
Attachment #8564777 - Flags: approval-gaia-v2.2?
Attachment #8564777 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.