Closed Bug 1133390 Opened 5 years ago Closed 5 years ago

onfocuschanged(false) will be notified twice.

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S6 (20feb)
Tracking Status
firefox36 --- wontfix
firefox37 --- wontfix
firefox38 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: allstars.chh, Assigned: allstars.chh)

References

Details

(Whiteboard: [p=1])

Attachments

(1 file)

Suppose there are two apps(browser-elements) called A and B.
Consider the following calling sequenece:

(1) A.setNFCFocus(true)  ---->                       Gecko
(2) A                    <---- onFocusChanged(true)  Gecko
(3) B.setNFCFocus(true)  ---->                       Gecko
(4) A                    <---- onFocusChanged(false) Gecko
(5) B                    <---- onFocusChanged(true)  Gecko
(6) A.setNFCFocus(false) ---->                       Gecko
(7) A                    <---- onFocusChanged(false) Gecko


In Step 6, setNFCFocus(false) is called on a Browser-Element
which has lost focus already, so step 7 should not be executed.
The onFocusChanged(false) for A is already done in Step 4.
Attached patch Patch.Splinter Review
Attachment #8564843 - Flags: review?(dlee)
Attachment #8564843 - Flags: review?(dlee) → review+
https://hg.mozilla.org/integration/b2g-inbound/rev/f379cddbf40e
Whiteboard: [p=1]
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8564843 [details] [diff] [review]
Patch.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1105666

User impact if declined: 
Right now we don't find any problem if declined. However we'd like to request to uplift this to prevent some potential problem.

Testing completed: 
Manually.

Risk to taking this patch (and alternatives if risky): 
No.

String or UUID changes made by this patch:
No
Attachment #8564843 - Flags: approval-mozilla-b2g37?
https://hg.mozilla.org/mozilla-central/rev/f379cddbf40e
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attachment #8564843 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.