Closed Bug 1133398 Opened 5 years ago Closed 5 years ago

Remove the code that restore the state of rild when it crashes

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: arthurcc, Assigned: arthurcc)

References

Details

(Whiteboard: [caf priority: p2][CR 814413])

Attachments

(1 file)

In bug 1038496 we implemented the code that restores the state of rild when it crashes. After bug 1067629 lands, gecko makes the state of rild always consistent to the current settings, so we can revert the change made in bug 1038496.
Status: NEW → ASSIGNED
Requesting 2.2 as this blocks a blocker bug 1067629.
blocking-b2g: --- → 2.2?
Blocking a blocker
blocking-b2g: 2.2? → 2.2+
Whiteboard: [CR 814413]
Whiteboard: [CR 814413] → [caf priority: p2][CR 814413]
Hi Arthur,

When can you make this change?

(In reply to Arthur Chen [:arthurcc] from comment #0)
> In bug 1038496 we implemented the code that restores the state of rild when
> it crashes. After bug 1067629 lands, gecko makes the state of rild always
> consistent to the current settings, so we can revert the change made in bug
> 1038496.


Thanks,
Mike
Flags: needinfo?(arthur.chen)
I was waiting for bug 1136585 resolved as I thought this bug depends on it. There should be no dependency between these two bugs after clarified with Hsinyi. I'll fix it today.
No longer depends on: 1136585
Flags: needinfo?(arthur.chen)
Comment on attachment 8569038 [details] [review]
[gaia] crh0716:1133398 > mozilla-b2g:master

Alive, could you help review this simple patch? It simply removes the expected state related logic and tests. Thanks!
Attachment #8569038 - Flags: review?(alive)
Comment on attachment 8569038 [details] [review]
[gaia] crh0716:1133398 > mozilla-b2g:master

r=me
Attachment #8569038 - Flags: review?(alive) → review+
Thanks!

master: 5c60afd706853712cab9df8d829b2ab9620a564a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8569038 [details] [review]
[gaia] crh0716:1133398 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: None. The fix is for qc test cases. 
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low. The removed logic is quite separated.
[String changes made]: None
Attachment #8569038 - Flags: approval-gaia-v2.2?
Attachment #8569038 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Needs rebasing for v2.2 uplift.
Flags: needinfo?(arthur.chen)
Target Milestone: --- → 2.2 S9 (3apr)
You need to log in before you can comment on or make changes to this bug.