Error while compiling on mozilla-central/gecko-dev

RESOLVED DUPLICATE of bug 1129686

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1129686
3 years ago
3 years ago

People

(Reporter: zimbabao, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125222139

Steps to reproduce:

System: 
$ uname -a
Linux rgaunker-W540 3.13.0-45-generic #74~precise1-Ubuntu SMP Thu Jan 15 20:21:55 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

g++
$ g++ --version
g++ (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
Copyright (C) 2011 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Steps to repro:
1. Bootstrapped the system to build ( https://developer.mozilla.org/en-US/docs/Simple_Firefox_build/Linux_and_MacOS_build_preparation )
2. Run ./mach build -j1



Actual results:

Build broke with following erro

 0:15.49 nsBaseWidget.o
 0:16.46 In file included from ../dist/include/gfx2DGlue.h:9:0,
 0:16.47                  from ../dist/include/Layers.h:20,
 0:16.47                  from ../dist/include/mozilla/layers/CompositorParent.h:19,
 0:16.47                  from /home/myhome/os/gecko-dev/widget/nsBaseWidget.cpp:10:
 0:16.47 ../dist/include/gfxPlatform.h:163:5: error: a class-key must be used when declaring a friend
 0:16.47 ../dist/include/gfxPlatform.h:163:5: error: friend declaration does not name a class or function
 0:17.87 In the directory  /home/myhome/os/gecko-dev/obj-x86_64-unknown-linux-gnu/widget
 0:17.87 The following command failed to execute properly:
 0:17.88 c++ -o nsBaseWidget.o -c -I../dist/stl_wrappers -I../dist/system_wrappers -include /home/myhome/os/gecko-dev/config/gcc_hidden_dso_handle.h -DMOZ_CROSS_PROCESS_IME -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DMOZ_GLUE_IN_PROGRAM -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/home/myhome/os/gecko-dev/widget -I. -I/home/myhome/os/gecko-dev/obj-x86_64-unknown-linux-gnu/ipc/ipdl/_ipdlheaders -I/home/myhome/os/gecko-dev/ipc/chromium/src -I/home/myhome/os/gecko-dev/ipc/glue -I/home/myhome/os/gecko-dev/layout/base -I/home/myhome/os/gecko-dev/layout/forms -I/home/myhome/os/gecko-dev/layout/generic -I/home/myhome/os/gecko-dev/layout/xul -I/home/myhome/os/gecko-dev/view -I/home/myhome/os/gecko-dev/widget -I/home/myhome/os/gecko-dev/widget/gtk -I../dist/include -I/home/myhome/os/gecko-dev/obj-x86_64-unknown-linux-gnu/dist/include/nspr -I/home/myhome/os/gecko-dev/obj-x86_64-unknown-linux-gnu/dist/include/nss -fPIC -DMOZILLA_CLIENT -include ../mozilla-config.h -MD -MP -MF .deps/nsBaseWidget.o.pp -Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -DDEBUG -DTRACING -g -fno-omit-frame-pointer -I/home/myhome/os/gecko-dev/widget/gtk/compat -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/gtk-unix-print-2.0 /home/myhome/os/gecko-dev/widget/nsBaseWidget.cpp
 0:17.88 make[5]: *** [nsBaseWidget.o] Error 1
 0:17.88 make[4]: *** [widget/target] Error 2
 0:17.88 make[3]: *** [compile] Error 2
 0:17.88 make[2]: *** [default] Error 2
 0:17.88 make[1]: *** [realbuild] Error 2
 0:17.88 make: *** [build] Error 2
 0:17.92 198 compiler warnings present.



Expected results:

Build houls have been succeful.
(Reporter)

Updated

3 years ago
Version: 35 Branch → Trunk
(Reporter)

Comment 1

3 years ago
Created attachment 8564855 [details] [diff] [review]
Patch to fix the build error.

Also thee has been similar issue reported earlier 
https://bugzilla.mozilla.org/show_bug.cgi?id=1033234

Updated

3 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
This was already fixed in bug 1129686 comment 16. If you update your m-c clone the problem should go away.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1129686
You need to log in before you can comment on or make changes to this bug.